<!doctype html >
<!--[if IE 8]>    <html class="ie8" lang="en"> <![endif]-->
<!--[if IE 9]>    <html class="ie9" lang="en"> <![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-GB"> <!--<![endif]-->
<head>
    
    <meta charset="UTF-8" />
    <meta name="viewport" content="width=device-width, initial-scale=1.0">
    <link rel="pingback" href="https://www.somtribune.com/xmlrpc.php" />
    <meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />
<link rel="icon" type="image/png" href="https://somtribune.com/wp-content/uploads/2016/07/logos.jpg"><link rel="apple-touch-icon" sizes="76x76" href="https://somtribune.com/wp-content/uploads/2016/07/logos.jpg"/><link rel="apple-touch-icon" sizes="120x120" href="https://somtribune.com/wp-content/uploads/2016/07/logos.jpg"/><link rel="apple-touch-icon" sizes="152x152" href="https://somtribune.com/wp-content/uploads/2016/07/logos.jpg"/><link rel="apple-touch-icon" sizes="114x114" href="https://somtribune.com/wp-content/uploads/2016/07/logos.jpg"/><link rel="apple-touch-icon" sizes="144x144" href="https://somtribune.com/wp-content/uploads/2016/07/logos.jpg"/>
	<!-- This site is optimized with the Yoast SEO plugin v19.6 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>Kenya: Hooligans Attempt to Harm IEBC Officials - SomTribune</title>
	<meta name="description" content="Nairobi hotel when a group of about 50 people raided and attempted to attack Independent Electoral and Boundaries Commission (IEBC) personnel" />
	<link rel="canonical" href="https://www.somtribune.com/2022/08/23/kenya-hooligans-attempt-to-harm-iebc-officials/" />
	<meta property="og:locale" content="en_GB" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Kenya: Hooligans Attempt to Harm IEBC Officials - SomTribune" />
	<meta property="og:description" content="Nairobi hotel when a group of about 50 people raided and attempted to attack Independent Electoral and Boundaries Commission (IEBC) personnel" />
	<meta property="og:url" content="https://www.somtribune.com/2022/08/23/kenya-hooligans-attempt-to-harm-iebc-officials/" />
	<meta property="og:site_name" content="SomTribune" />
	<meta property="article:published_time" content="2022-08-23T17:48:04+00:00" />
	<meta property="og:image" content="https://www.somtribune.com/wp-content/uploads/2022/08/IEBC.jpg" />
	<meta property="og:image:width" content="624" />
	<meta property="og:image:height" content="351" />
	<meta property="og:image:type" content="image/jpeg" />
	<meta name="author" content="News Desk" />
	<meta name="twitter:card" content="summary" />
	<meta name="twitter:label1" content="Written by" />
	<meta name="twitter:data1" content="News Desk" />
	<meta name="twitter:label2" content="Estimated reading time" />
	<meta name="twitter:data2" content="3 minutes" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Article","@id":"https://www.somtribune.com/2022/08/23/kenya-hooligans-attempt-to-harm-iebc-officials/#article","isPartOf":{"@id":"https://www.somtribune.com/2022/08/23/kenya-hooligans-attempt-to-harm-iebc-officials/"},"author":{"name":"News Desk","@id":"https://www.somtribune.com/#/schema/person/9e97181ebd3336cf4b2d7e8126d6271f"},"headline":"Kenya: Hooligans Attempt to Harm IEBC Officials","datePublished":"2022-08-23T17:48:04+00:00","dateModified":"2022-08-23T17:48:04+00:00","mainEntityOfPage":{"@id":"https://www.somtribune.com/2022/08/23/kenya-hooligans-attempt-to-harm-iebc-officials/"},"wordCount":564,"commentCount":0,"publisher":{"@id":"https://www.somtribune.com/#organization"},"image":{"@id":"https://www.somtribune.com/2022/08/23/kenya-hooligans-attempt-to-harm-iebc-officials/#primaryimage"},"thumbnailUrl":"https://www.somtribune.com/wp-content/uploads/2022/08/IEBC.jpg","keywords":["IEBC","Kenya","Kenya elections","Law and order"],"articleSection":["Kenya","Law &amp; Order","Politics/Diplomacy"],"inLanguage":"en-GB","potentialAction":[{"@type":"CommentAction","name":"Comment","target":["https://www.somtribune.com/2022/08/23/kenya-hooligans-attempt-to-harm-iebc-officials/#respond"]}]},{"@type":"WebPage","@id":"https://www.somtribune.com/2022/08/23/kenya-hooligans-attempt-to-harm-iebc-officials/","url":"https://www.somtribune.com/2022/08/23/kenya-hooligans-attempt-to-harm-iebc-officials/","name":"Kenya: Hooligans Attempt to Harm IEBC Officials - SomTribune","isPartOf":{"@id":"https://www.somtribune.com/#website"},"primaryImageOfPage":{"@id":"https://www.somtribune.com/2022/08/23/kenya-hooligans-attempt-to-harm-iebc-officials/#primaryimage"},"image":{"@id":"https://www.somtribune.com/2022/08/23/kenya-hooligans-attempt-to-harm-iebc-officials/#primaryimage"},"thumbnailUrl":"https://www.somtribune.com/wp-content/uploads/2022/08/IEBC.jpg","datePublished":"2022-08-23T17:48:04+00:00","dateModified":"2022-08-23T17:48:04+00:00","description":"Nairobi hotel when a group of about 50 people raided and attempted to attack Independent Electoral and Boundaries Commission (IEBC) personnel","breadcrumb":{"@id":"https://www.somtribune.com/2022/08/23/kenya-hooligans-attempt-to-harm-iebc-officials/#breadcrumb"},"inLanguage":"en-GB","potentialAction":[{"@type":"ReadAction","target":["https://www.somtribune.com/2022/08/23/kenya-hooligans-attempt-to-harm-iebc-officials/"]}]},{"@type":"ImageObject","inLanguage":"en-GB","@id":"https://www.somtribune.com/2022/08/23/kenya-hooligans-attempt-to-harm-iebc-officials/#primaryimage","url":"https://www.somtribune.com/wp-content/uploads/2022/08/IEBC.jpg","contentUrl":"https://www.somtribune.com/wp-content/uploads/2022/08/IEBC.jpg","width":624,"height":351},{"@type":"BreadcrumbList","@id":"https://www.somtribune.com/2022/08/23/kenya-hooligans-attempt-to-harm-iebc-officials/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://www.somtribune.com/"},{"@type":"ListItem","position":2,"name":"Kenya: Hooligans Attempt to Harm IEBC Officials"}]},{"@type":"WebSite","@id":"https://www.somtribune.com/#website","url":"https://www.somtribune.com/","name":"SomTribune","description":"Daily Horn News &amp; Updates","publisher":{"@id":"https://www.somtribune.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://www.somtribune.com/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-GB"},{"@type":"Organization","@id":"https://www.somtribune.com/#organization","name":"Somtribune","url":"https://www.somtribune.com/","sameAs":[],"logo":{"@type":"ImageObject","inLanguage":"en-GB","@id":"https://www.somtribune.com/#/schema/logo/image/","url":"https://www.somtribune.com/wp-content/uploads/2018/07/SomTribune1-1.png","contentUrl":"https://www.somtribune.com/wp-content/uploads/2018/07/SomTribune1-1.png","width":1003,"height":1024,"caption":"Somtribune"},"image":{"@id":"https://www.somtribune.com/#/schema/logo/image/"}},{"@type":"Person","@id":"https://www.somtribune.com/#/schema/person/9e97181ebd3336cf4b2d7e8126d6271f","name":"News Desk","image":{"@type":"ImageObject","inLanguage":"en-GB","@id":"https://www.somtribune.com/#/schema/person/image/","url":"https://secure.gravatar.com/avatar/9ee783b426530732c3ff985ea907a5fe?s=96&d=mm&r=g","contentUrl":"https://secure.gravatar.com/avatar/9ee783b426530732c3ff985ea907a5fe?s=96&d=mm&r=g","caption":"News Desk"},"url":"https://www.somtribune.com/author/news-desk/"}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//secure.gravatar.com' />
<link rel='dns-prefetch' href='//www.google.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link rel='dns-prefetch' href='//widgets.wp.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//0.gravatar.com' />
<link rel='dns-prefetch' href='//1.gravatar.com' />
<link rel='dns-prefetch' href='//2.gravatar.com' />
<link rel="alternate" type="application/rss+xml" title="SomTribune &raquo; Feed" href="https://www.somtribune.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="SomTribune &raquo; Comments Feed" href="https://www.somtribune.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="SomTribune &raquo; Kenya: Hooligans Attempt to Harm IEBC Officials Comments Feed" href="https://www.somtribune.com/2022/08/23/kenya-hooligans-attempt-to-harm-iebc-officials/feed/" />
		<!-- This site uses the Google Analytics by ExactMetrics plugin v7.5.0 - Using Analytics tracking - https://www.exactmetrics.com/ -->
							<script src="//www.googletagmanager.com/gtag/js?id=UA-162795354-1"  data-cfasync="false" data-wpfc-render="false" type="text/javascript" async></script>
			<script data-cfasync="false" data-wpfc-render="false" type="text/javascript">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</script>
				<!-- / Google Analytics by ExactMetrics -->
		<script type="text/javascript">
window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.somtribune.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.9.1"}};
/*! This file is auto-generated */
!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([10084,65039,8205,55357,56613],[10084,65039,8203,55357,56613])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 0.07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='gtranslate-style-css'  href='https://www.somtribune.com/wp-content/plugins/gtranslate/gtranslate-style24.css?ver=5.9.1' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://www.somtribune.com/wp-includes/css/dist/block-library/style.min.css?ver=5.9.1' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='mediaelement-css'  href='https://www.somtribune.com/wp-includes/js/mediaelement/mediaelementplayer-legacy.min.css?ver=4.2.16' type='text/css' media='all' />
<link rel='stylesheet' id='wp-mediaelement-css'  href='https://www.somtribune.com/wp-includes/js/mediaelement/wp-mediaelement.min.css?ver=5.9.1' type='text/css' media='all' />
<style id='global-styles-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='contact-form-7-css'  href='https://www.somtribune.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=5.6.2' type='text/css' media='all' />
<link rel='stylesheet' id='orchestrated_corona_virus_banner-frontend-css'  href='https://www.somtribune.com/wp-content/plugins/corona-virus-covid-19-banner/assets/css/frontend.css?ver=1.7.0.6' type='text/css' media='all' />
<link rel='stylesheet' id='orchestrated_corona_virus_banner-font-css'  href='https://fonts.googleapis.com/css2?family=Open+Sans%3Awght%40300%3B400%3B600%3B700&#038;display=swap&#038;ver=1.7.0.6' type='text/css' media='all' />
<link rel='stylesheet' id='td-plugin-multi-purpose-css'  href='https://www.somtribune.com/wp-content/plugins/td-composer/td-multi-purpose/style.css?ver=23f7cf05c1213c4bc7a6753a64c58bf1' type='text/css' media='all' />
<link rel='stylesheet' id='google-fonts-style-css'  href='https://fonts.googleapis.com/css?family=Open+Sans%3A400%2C600%2C700%7CRoboto%3A400%2C500%2C700&#038;display=swap&#038;ver=11.4.1' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-css'  href='https://www.somtribune.com/wp-content/themes/Newspaper/style.css?ver=11.4.1' type='text/css' media='all' />
<style id='td-theme-inline-css' type='text/css'>
    
        @media (max-width: 767px) {
            .td-header-desktop-wrap {
                display: none;
            }
        }
        @media (min-width: 767px) {
            .td-header-mobile-wrap {
                display: none;
            }
        }
    
	
</style>
<link rel='stylesheet' id='js_composer_front-css'  href='https://www.somtribune.com/wp-content/plugins/js_composer/assets/css/js_composer.min.css?ver=6.7.0' type='text/css' media='all' />
<link rel='stylesheet' id='td-legacy-framework-front-style-css'  href='https://www.somtribune.com/wp-content/plugins/td-composer/legacy/Newspaper/assets/css/td_legacy_main.css?ver=23f7cf05c1213c4bc7a6753a64c58bf1' type='text/css' media='all' />
<link rel='stylesheet' id='td-standard-pack-framework-front-style-css'  href='https://www.somtribune.com/wp-content/plugins/td-standard-pack/Newspaper/assets/css/td_standard_pack_main.css?ver=4168705b165f7662fff7e5fdf2db6ef8' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-demo-style-css'  href='https://www.somtribune.com/wp-content/plugins/td-composer/legacy/Newspaper/includes/demos/magazine/demo_style.css?ver=11.4.1' type='text/css' media='all' />
<link rel='stylesheet' id='social-logos-css'  href='https://www.somtribune.com/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?ver=11.2' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://www.somtribune.com/wp-content/plugins/jetpack/css/jetpack.css?ver=11.2' type='text/css' media='all' />
<script type='text/javascript' src='https://www.somtribune.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script>
<script type='text/javascript' src='https://www.somtribune.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' id='jetpack_related-posts-js-extra'>
/* <![CDATA[ */
var related_posts_js_options = {"post_heading":"h4"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.somtribune.com/wp-content/plugins/jetpack/_inc/build/related-posts/related-posts.min.js?ver=20211209' id='jetpack_related-posts-js'></script>
<script type='text/javascript' src='https://www.somtribune.com/wp-content/plugins/google-analytics-dashboard-for-wp/assets/js/frontend-gtag.min.js?ver=7.5.0' id='exactmetrics-frontend-script-js'></script>
<script data-cfasync="false" data-wpfc-render="false" type="text/javascript" id='exactmetrics-frontend-script-js-extra'>/* <![CDATA[ */
var exactmetrics_frontend = {"js_events_tracking":"true","download_extensions":"zip,mp3,mpeg,pdf,docx,pptx,xlsx,rar","inbound_paths":"[{\"path\":\"\\\/go\\\/\",\"label\":\"affiliate\"},{\"path\":\"\\\/recommend\\\/\",\"label\":\"affiliate\"}]","home_url":"https:\/\/www.somtribune.com","hash_tracking":"false","ua":"UA-162795354-1","v4_id":""};/* ]]> */
</script>
<script type='text/javascript' src='https://www.somtribune.com/wp-content/plugins/corona-virus-covid-19-banner/assets/js/frontend.min.js?ver=1.7.0.6' id='orchestrated_corona_virus_banner-frontend-js'></script>
<script type='text/javascript' src='https://www.somtribune.com/wp-content/plugins/corona-virus-covid-19-banner/assets/js/js.cookie.min.js?ver=1.7.0.6' id='orchestrated_corona_virus_banner-jscookie-js'></script>
<link rel="https://api.w.org/" href="https://www.somtribune.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.somtribune.com/wp-json/wp/v2/posts/64460" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.somtribune.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.somtribune.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.9.1" />
<link rel='shortlink' href='https://wp.me/p5sVvn-gLG' />
<link rel="alternate" type="application/json+oembed" href="https://www.somtribune.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.somtribune.com%2F2022%2F08%2F23%2Fkenya-hooligans-attempt-to-harm-iebc-officials%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.somtribune.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.somtribune.com%2F2022%2F08%2F23%2Fkenya-hooligans-attempt-to-harm-iebc-officials%2F&#038;format=xml" />
<link type="text/css" rel="stylesheet" href="https://www.somtribune.com/wp-content/plugins/simple-pull-quote/css/simple-pull-quote.css" />
<style>img#wpstats{display:none}</style>
	<!--[if lt IE 9]><script src="https://cdnjs.cloudflare.com/ajax/libs/html5shiv/3.7.3/html5shiv.js"></script><![endif]-->
    			<script>
				window.tdwGlobal = {"adminUrl":"https:\/\/www.somtribune.com\/wp-admin\/","wpRestNonce":"46489b1150","wpRestUrl":"https:\/\/www.somtribune.com\/wp-json\/","permalinkStructure":"\/%year%\/%monthnum%\/%day%\/%postname%\/"};
			</script>
			    <script>
        window.tdaGlobal = {"adminUrl":"https:\/\/www.somtribune.com\/wp-admin\/","wpRestNonce":"46489b1150","wpRestUrl":"https:\/\/www.somtribune.com\/wp-json\/","permalinkStructure":"\/%year%\/%monthnum%\/%day%\/%postname%\/","postId":64460};
    </script>
          <meta name="onesignal" content="wordpress-plugin"/>
            <script>

      window.OneSignal = window.OneSignal || [];

      OneSignal.push( function() {
        OneSignal.SERVICE_WORKER_UPDATER_PATH = "OneSignalSDKUpdaterWorker.js.php";
                      OneSignal.SERVICE_WORKER_PATH = "OneSignalSDKWorker.js.php";
                      OneSignal.SERVICE_WORKER_PARAM = { scope: "/" };
        OneSignal.setDefaultNotificationUrl("https://www.somtribune.com");
        var oneSignal_options = {};
        window._oneSignalInitOptions = oneSignal_options;

        oneSignal_options['wordpress'] = true;
oneSignal_options['appId'] = 'b410c14c-10b1-4299-9230-3013cf954aa3';
oneSignal_options['allowLocalhostAsSecureOrigin'] = true;
oneSignal_options['welcomeNotification'] = { };
oneSignal_options['welcomeNotification']['title'] = "Welcome to SOMTRIBUNE updates!";
oneSignal_options['welcomeNotification']['message'] = "Thank you for subscribing to Somtribune";
oneSignal_options['welcomeNotification']['url'] = "https://www.somtribune.com";
oneSignal_options['path'] = "https://www.somtribune.com/wp-content/plugins/onesignal-free-web-push-notifications/sdk_files/";
oneSignal_options['safari_web_id'] = "https://www.somtribune.com";
oneSignal_options['promptOptions'] = { };
oneSignal_options['promptOptions']['actionMessage'] = "Subscribe to Somtribune Updates";
oneSignal_options['promptOptions']['exampleNotificationMessageDesktop'] = "Somtribune news update!";
oneSignal_options['promptOptions']['exampleNotificationTitleMobile'] = "Somtribune news update!";
oneSignal_options['promptOptions']['exampleNotificationMessageMobile'] = "Somtribune News Update";
oneSignal_options['promptOptions']['siteName'] = "https://www.somtribune.com";
oneSignal_options['promptOptions']['autoAcceptTitle'] = "Click Allow";
oneSignal_options['notifyButton'] = { };
oneSignal_options['notifyButton']['enable'] = true;
oneSignal_options['notifyButton']['position'] = 'bottom-right';
oneSignal_options['notifyButton']['theme'] = 'default';
oneSignal_options['notifyButton']['size'] = 'medium';
oneSignal_options['notifyButton']['displayPredicate'] = function() {
              return OneSignal.isPushNotificationsEnabled()
                      .then(function(isPushEnabled) {
                          return !isPushEnabled;
                      });
            };
oneSignal_options['notifyButton']['showCredit'] = true;
oneSignal_options['notifyButton']['text'] = {};
oneSignal_options['notifyButton']['text']['tip.state.unsubscribed'] = 'Hope to see you back. Any suggestions?';
oneSignal_options['notifyButton']['text']['tip.state.subscribed'] = 'WELCOME! Subscribed to one of the most resourceful news updates in the Horn.';
oneSignal_options['notifyButton']['text']['message.action.subscribed'] = 'Thank you for Subscribing to Somtribune';
oneSignal_options['notifyButton']['text']['message.action.resubscribed'] = 'Happy to see you back!';
oneSignal_options['notifyButton']['text']['message.action.unsubscribed'] = 'Sorry to see you go.';
oneSignal_options['notifyButton']['text']['dialog.main.title'] = 'Somtribune';
oneSignal_options['notifyButton']['text']['dialog.main.button.subscribe'] = 'SUBSCRIBE for SOMTRIBUNE Updates';
oneSignal_options['notifyButton']['colors'] = {};
oneSignal_options['notifyButton']['colors']['badge.foreground'] = 'White';
oneSignal_options['notifyButton']['colors']['badge.bordercolor'] = 'Red';
oneSignal_options['notifyButton']['offset'] = {};
                OneSignal.init(window._oneSignalInitOptions);
                      });

      function documentInitOneSignal() {
        var oneSignal_elements = document.getElementsByClassName("OneSignal-prompt");

        var oneSignalLinkClickHandler = function(event) { OneSignal.push(['registerForPushNotifications']); event.preventDefault(); };        for(var i = 0; i < oneSignal_elements.length; i++)
          oneSignal_elements[i].addEventListener('click', oneSignalLinkClickHandler, false);
      }

      if (document.readyState === 'complete') {
           documentInitOneSignal();
      }
      else {
           window.addEventListener("load", function(event){
               documentInitOneSignal();
          });
      }
    </script>
<meta name="generator" content="Powered by WPBakery Page Builder - drag and drop page builder for WordPress."/>

<!-- JS generated by theme -->

<script>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</script>


<!-- Header style compiled by theme -->

<style>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</style>

<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-29207163-6', 'auto');
  ga('send', 'pageview');

</script>


<script type="application/ld+json">
    {
        "@context": "http://schema.org",
        "@type": "BreadcrumbList",
        "itemListElement": [
            {
                "@type": "ListItem",
                "position": 1,
                "item": {
                    "@type": "WebSite",
                    "@id": "https://www.somtribune.com/",
                    "name": "Home"
                }
            },
            {
                "@type": "ListItem",
                "position": 2,
                    "item": {
                    "@type": "WebPage",
                    "@id": "https://www.somtribune.com/category/worldinternational/africa/",
                    "name": "Africa"
                }
            }
            ,{
                "@type": "ListItem",
                "position": 3,
                    "item": {
                    "@type": "WebPage",
                    "@id": "https://www.somtribune.com/category/worldinternational/africa/kenya/",
                    "name": "Kenya"                                
                }
            }
            ,{
                "@type": "ListItem",
                "position": 4,
                    "item": {
                    "@type": "WebPage",
                    "@id": "https://www.somtribune.com/2022/08/23/kenya-hooligans-attempt-to-harm-iebc-officials/",
                    "name": "Kenya: Hooligans Attempt to Harm IEBC Officials"                                
                }
            }    
        ]
    }
</script>
<link rel="icon" href="https://www.somtribune.com/wp-content/uploads/2017/01/aHOlC4xN_400x400-150x150.jpeg" sizes="32x32" />
<link rel="icon" href="https://www.somtribune.com/wp-content/uploads/2017/01/aHOlC4xN_400x400.jpeg" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.somtribune.com/wp-content/uploads/2017/01/aHOlC4xN_400x400.jpeg" />
<meta name="msapplication-TileImage" content="https://www.somtribune.com/wp-content/uploads/2017/01/aHOlC4xN_400x400.jpeg" />

<!-- Button style compiled by theme -->

<style>
    .tdm_block_column_content:hover .tdm-col-content-title-url .tdm-title,
                .tds-button2 .tdm-btn-text,
                .tds-button2 i,
                .tds-button5:hover .tdm-btn-text,
                .tds-button5:hover i,
                .tds-button6 .tdm-btn-text,
                .tds-button6 i,
                .tdm_block_list .tdm-list-item i,
                .tdm_block_pricing .tdm-pricing-feature i,
                body .tdm-social-item i {
                    color: #c90000;
                }
                .tds-button1,
                .tds-button6:after,
                .tds-title2 .tdm-title-line:after,
                .tds-title3 .tdm-title-line:after,
                .tdm_block_pricing.tdm-pricing-featured:before,
                .tdm_block_pricing.tds_pricing2_block.tdm-pricing-featured .tdm-pricing-header,
                .tds-progress-bar1 .tdm-progress-bar:after,
                .tds-progress-bar2 .tdm-progress-bar:after,
                .tds-social3 .tdm-social-item {
                    background-color: #c90000;
                }
                .tds-button2:before,
                .tds-button6:before,
                .tds-progress-bar3 .tdm-progress-bar:after {
                  border-color: #c90000;
                }
                .tdm-btn-style1 {
					background-color: #c90000;
				}
				.tdm-btn-style2:before {
				    border-color: #c90000;
				}
				.tdm-btn-style2 {
				    color: #c90000;
				}
				.tdm-btn-style3 {
				    -webkit-box-shadow: 0 2px 16px #c90000;
                    -moz-box-shadow: 0 2px 16px #c90000;
                    box-shadow: 0 2px 16px #c90000;
				}
				.tdm-btn-style3:hover {
				    -webkit-box-shadow: 0 4px 26px #c90000;
                    -moz-box-shadow: 0 4px 26px #c90000;
                    box-shadow: 0 4px 26px #c90000;
				}
</style>

<noscript><style> .wpb_animate_when_almost_visible { opacity: 1; }</style></noscript>	<style id="tdw-css-placeholder"></style></head>

<body class="post-template-default single single-post postid-64460 single-format-standard td-standard-pack kenya-hooligans-attempt-to-harm-iebc-officials global-block-template-1 td-magazine single_template_2 white-menu wpb-js-composer js-comp-ver-6.7.0 vc_responsive td-animation-stack-type0 td-full-layout" itemscope="itemscope" itemtype="https://schema.org/WebPage">

            <div class="td-scroll-up  td-hide-scroll-up-on-mob" style="display:none;"><i class="td-icon-menu-up"></i></div>
    
    <div class="td-menu-background"></div>
<div id="td-mobile-nav">
    <div class="td-mobile-container">
        <!-- mobile menu top section -->
        <div class="td-menu-socials-wrap">
            <!-- socials -->
            <div class="td-menu-socials">
                
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.facebook.com/somtribune/?fref=ts" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://twitter.com/somtribune" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span>            </div>
            <!-- close button -->
            <div class="td-mobile-close">
                <a href="#" aria-label="Close"><i class="td-icon-close-mobile"></i></a>
            </div>
        </div>

        <!-- login section -->
                    <div class="td-menu-login-section">
                
    <div class="td-guest-wrap">
        <div class="td-menu-login"><a id="login-link-mob">Sign in</a> <span></span><a id="register-link-mob">Join</a></div>
    </div>
            </div>
        
        <!-- menu section -->
        <div class="td-mobile-content">
            <div class="menu-main-menu-container"><ul id="menu-main-menu" class="td-mobile-main-menu"><li id="menu-item-26091" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-first menu-item-26091"><a href="https://www.somtribune.com/">Home</a></li>
<li id="menu-item-64391" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-64391"><a href="https://www.somtribune.com/category/featured/">Featured</a></li>
<li id="menu-item-61578" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-61578"><a href="https://www.somtribune.com/category/somaliland/">News<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
	<li id="menu-item-24" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-24"><a href="https://www.somtribune.com/category/somaliland/">Somaliland</a></li>
	<li id="menu-item-23" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-23"><a href="https://www.somtribune.com/category/somalia/">Somalia</a></li>
	<li id="menu-item-26" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-26"><a href="https://www.somtribune.com/category/worldinternational/">World News/International</a></li>
	<li id="menu-item-18" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-18"><a href="https://www.somtribune.com/category/worldinternational/africa/">Africa</a></li>
	<li id="menu-item-25" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-25"><a href="https://www.somtribune.com/category/sports/">Sports</a></li>
</ul>
</li>
<li id="menu-item-19" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-19"><a href="https://www.somtribune.com/category/economy/">Economy/Business<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
	<li id="menu-item-0" class="menu-item-0"><a href="https://www.somtribune.com/category/economy/finance/">Finance</a></li>
	<li class="menu-item-0"><a href="https://www.somtribune.com/category/economy/markets/">Markets</a></li>
</ul>
</li>
<li id="menu-item-21" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-21"><a href="https://www.somtribune.com/category/editorial/">Editorial</a></li>
<li id="menu-item-22" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22"><a href="https://www.somtribune.com/category/opinionanalysis/">Opinion/Analysis</a></li>
<li id="menu-item-40667" class="menu-item menu-item-type-taxonomy menu-item-object-post_format menu-item-40667"><a href="https://www.somtribune.com/type/video/">Videos</a></li>
<li id="menu-item-1087" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1087"><a href="https://www.somtribune.com/contact-us/">Contact Us</a></li>
<li id="menu-item-64392" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-64392"><a href="https://www.somtribune.com/category/featured/">Featured</a></li>
</ul></div>        </div>
    </div>

    <!-- register/login section -->
            <div id="login-form-mobile" class="td-register-section">
            
            <div id="td-login-mob" class="td-login-animation td-login-hide-mob">
            	<!-- close button -->
	            <div class="td-login-close">
	                <a href="#" aria-label="Back" class="td-back-button"><i class="td-icon-read-down"></i></a>
	                <div class="td-login-title">Sign in</div>
	                <!-- close button -->
		            <div class="td-mobile-close">
		                <a href="#" aria-label="Close"><i class="td-icon-close-mobile"></i></a>
		            </div>
	            </div>
	            <form class="td-login-form-wrap" action="#" method="post">
	                <div class="td-login-panel-title"><span>Welcome!</span>Log into your account</div>
	                <div class="td_display_err"></div>
	                <div class="td-login-inputs"><input class="td-login-input" autocomplete="username" type="text" name="login_email" id="login_email-mob" value="" required><label for="login_email-mob">your username</label></div>
	                <div class="td-login-inputs"><input class="td-login-input" autocomplete="current-password" type="password" name="login_pass" id="login_pass-mob" value="" required><label for="login_pass-mob">your password</label></div>
	                <input type="button" name="login_button" id="login_button-mob" class="td-login-button" value="LOG IN">
	                
	                <div class="td-login-info-text">
	                <a href="#" id="forgot-pass-link-mob">Forgot your password?</a>
	                </div>
	                <div class="td-login-register-link">
	                <a id="signin-register-link-mob">Create an account</a>
	                </div>
	                
	                

                </form>
            </div>

            
            
            
            <div id="td-register-mob" class="td-login-animation td-login-hide-mob">
            	<!-- close button -->
	            <div class="td-register-close">
	                <a href="#" aria-label="Back" class="td-back-button"><i class="td-icon-read-down"></i></a>
	                <div class="td-login-title">Sign up</div>
	                <!-- close button -->
		            <div class="td-mobile-close">
		                <a href="#" aria-label="Close"><i class="td-icon-close-mobile"></i></a>
		            </div>
	            </div>
            	<div class="td-login-panel-title"><span>Welcome!</span>Register for an account</div>
                <form class="td-login-form-wrap" action="#" method="post">
	                <div class="td_display_err"></div>
	                <div class="td-login-inputs"><input class="td-login-input" type="text" name="register_email" id="register_email-mob" value="" required><label for="register_email-mob">your email</label></div>
	                <div class="td-login-inputs"><input class="td-login-input" type="text" name="register_user" id="register_user-mob" value="" required><label for="register_user-mob">your username</label></div>
	                <input type="button" name="register_button" id="register_button-mob" class="td-login-button" value="REGISTER">
	                
	                <div class="td-login-info-text">A password will be e-mailed to you.</div>
	                
                </form>
            </div>
            
            <div id="td-forgot-pass-mob" class="td-login-animation td-login-hide-mob">
                <!-- close button -->
	            <div class="td-forgot-pass-close">
	                <a href="#" aria-label="Back" class="td-back-button"><i class="td-icon-read-down"></i></a>
	                <div class="td-login-title">Password recovery</div>
	            </div>
	            <div class="td-login-form-wrap">
	                <div class="td-login-panel-title">Recover your password</div>
	                <div class="td_display_err"></div>
	                <div class="td-login-inputs"><input class="td-login-input" type="text" name="forgot_email" id="forgot_email-mob" value="" required><label for="forgot_email-mob">your email</label></div>
	                <input type="button" name="forgot_button" id="forgot_button-mob" class="td-login-button" value="Send My Pass">
                </div>
            </div>
        </div>
    </div>    <div class="td-search-background"></div>
<div class="td-search-wrap-mob">
	<div class="td-drop-down-search">
		<form method="get" class="td-search-form" action="https://www.somtribune.com/">
			<!-- close button -->
			<div class="td-search-close">
				<a href="#"><i class="td-icon-close-mobile"></i></a>
			</div>
			<div role="search" class="td-search-input">
				<span>Search</span>
				<input id="td-header-search-mob" type="text" value="" name="s" autocomplete="off" />
			</div>
		</form>
		<div id="td-aj-search-mob" class="td-ajax-search-flex"></div>
	</div>
</div>

    <div id="td-outer-wrap" class="td-theme-wrap">
    
        
            <div class="tdc-header-wrap ">

            <!--
Header style multipurpose 3
-->


<div class="td-header-wrap tdm-header tdm-header-style-3 ">
    
            <div class="td-header-top-menu-full td-container-wrap ">
            <div class="td-container td-header-row td-header-top-menu">
                
    <div class="top-bar-style-1">
        
<div class="td-header-sp-top-menu">


	        <div class="td_data_time">
            <div >

                Wednesday, August 24, 2022
            </div>
        </div>
    <ul class="top-header-menu td_ul_login"><li class="menu-item"><a class="td-login-modal-js menu-item" href="#login-form" data-effect="mpf-td-login-effect">Sign in / Join</a><span class="td-sp-ico-login td_sp_login_ico_style"></span></li></ul></div>
        <div class="td-header-sp-top-widget">
    
    
        
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.facebook.com/somtribune/?fref=ts" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://twitter.com/somtribune" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span>    </div>    </div>

<!-- LOGIN MODAL -->

                <div id="login-form" class="white-popup-block mfp-hide mfp-with-anim">
                    <div class="td-login-wrap">
                        <a href="#" aria-label="Back" class="td-back-button"><i class="td-icon-modal-back"></i></a>
                        <div id="td-login-div" class="td-login-form-div td-display-block">
                            <div class="td-login-panel-title">Sign in</div>
                            <div class="td-login-panel-descr">Welcome! Log into your account</div>
                            <div class="td_display_err"></div>
                            <form id="loginForm" action="#" method="post">
                            <div class="td-login-inputs"><input class="td-login-input" autocomplete="username" type="text" name="login_email" id="login_email" value="" required><label for="login_email">your username</label></div>
	                        <div class="td-login-inputs"><input class="td-login-input" autocomplete="current-password" type="password" name="login_pass" id="login_pass" value="" required><label for="login_pass">your password</label></div>
                            <input type="button"  name="login_button" id="login_button" class="wpb_button btn td-login-button" value="Login">
                            
                            </form>
                            <div class="td-login-info-text"><a href="#" id="forgot-pass-link">Forgot your password? Get help</a></div>
                            
                            
                            <a id="register-link">Create an account</a>
                            
                        </div>

                        
                <div id="td-register-div" class="td-login-form-div td-display-none">
                    <div class="td-login-panel-title">Create an account</div>
                    <div class="td-login-panel-descr">Welcome! Register for an account</div>
                    <div class="td_display_err"></div>
                    <form id="registerForm" action="#" method="post">
                    <div class="td-login-inputs"><input class="td-login-input" type="text" name="register_email" id="register_email" value="" required><label for="register_email">your email</label></div>
                    <div class="td-login-inputs"><input class="td-login-input" type="text" name="register_user" id="register_user" value="" required><label for="register_user">your username</label></div>
                    <input type="button" name="register_button" id="register_button" class="wpb_button btn td-login-button" value="Register">
                    
                    </form>
                    <div class="td-login-info-text">A password will be e-mailed to you.</div>
                    
                </div>

                         <div id="td-forgot-pass-div" class="td-login-form-div td-display-none">
                            <div class="td-login-panel-title">Password recovery</div>
                            <div class="td-login-panel-descr">Recover your password</div>
                            <div class="td_display_err"></div>
                            <form id="forgotpassForm" action="#" method="post">
                            <div class="td-login-inputs"><input class="td-login-input" type="text" name="forgot_email" id="forgot_email" value="" required><label for="forgot_email">your email</label></div>
                            <input type="button" name="forgot_button" id="forgot_button" class="wpb_button btn td-login-button" value="Send My Password">
                            </form>
                            <div class="td-login-info-text">A password will be e-mailed to you.</div>
                        </div>
                        
                        
                    </div>
                </div>
                            </div>
        </div>
    
    <div class="td-header-menu-wrap-full td-container-wrap ">
        <div class="td-header-menu-wrap td-header-gradient td-header-menu-no-search">
            <div class="td-container td-header-row td-header-main-menu">
                <div class="tdm-menu-btns-socials">
            <div class="header-search-wrap">
            <div class="td-search-btns-wrap">
                <a id="td-header-search-button" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
                <a id="td-header-search-button-mob" href="#" role="button" aria-label="Search" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
            </div>

            <div class="td-drop-down-search">
                <form method="get" class="td-search-form" action="https://www.somtribune.com/">
                    <div role="search" class="td-head-form-search-wrap">
                        <input id="td-header-search" type="text" value="" name="s" autocomplete="off" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="td-header-search-top" value="Search" />
                    </div>
                </form>
                <div id="td-aj-search"></div>
            </div>
        </div>
    
    
    </div>

<div id="td-header-menu" role="navigation">
    <div id="td-top-mobile-toggle"><a href="#" aria-label="mobile-toggle"><i class="td-icon-font td-icon-mobile"></i></a></div>
    <div class="td-main-menu-logo td-logo-in-menu">
        		<a class="td-mobile-logo td-sticky-mobile" href="https://www.somtribune.com/">
			<img class="td-retina-data" data-retina="https://somtribune.com/wp-content/uploads/2016/07/Logoo-300x90.png" src="https://somtribune.com/wp-content/uploads/2016/07/Logoo-300x90.png" alt=""/>
		</a>
			<a class="td-header-logo td-sticky-mobile" href="https://www.somtribune.com/">
			<img class="td-retina-data" data-retina="https://somtribune.com/wp-content/uploads/2016/07/Somtr-300x99.png" src="https://somtribune.com/wp-content/uploads/2016/07/Logoo-300x90.png" alt=""/>
			<span class="td-visual-hidden">SomTribune</span>
		</a>
	    </div>
    <div class="menu-main-menu-container"><ul id="menu-main-menu-1" class="sf-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-first td-menu-item td-normal-menu menu-item-26091"><a href="https://www.somtribune.com/">Home</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-64391"><a href="https://www.somtribune.com/category/featured/">Featured</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children td-menu-item td-mega-menu menu-item-61578"><a href="https://www.somtribune.com/category/somaliland/">News</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu tdi_1 td-no-subcats td_with_ajax_pagination td-pb-border-top td_block_template_1 td_ajax_preloading_preload"  data-td-block-uid="tdi_1" ><script>var block_tdi_1 = new tdBlock();
block_tdi_1.id = "tdi_1";
block_tdi_1.atts = '{"limit":"5","td_column_number":3,"ajax_pagination":"next_prev","category_id":"2","show_child_cat":30,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"preload","block_type":"td_block_mega_menu","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"tdi_1","tdc_css_class":"tdi_1","tdc_css_class_style":"tdi_1_rand_style"}';
block_tdi_1.td_column_number = "3";
block_tdi_1.block_type = "td_block_mega_menu";
block_tdi_1.post_count = "5";
block_tdi_1.found_posts = "3196";
block_tdi_1.header_color = "";
block_tdi_1.ajax_pagination_infinite_stop = "";
block_tdi_1.max_num_pages = "640";
tdBlocksArray.push(block_tdi_1);
</script><div id=tdi_1 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.somtribune.com/2022/08/23/somaliland-can-help-the-united-states-win-the-new-cold-war/" rel="bookmark" class="td-image-wrap " title="Somaliland Can Help The United States Win The New Cold War" ><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="Somaliland Can Help The United States Win The New Cold War" data-type="image_tag" data-img-url="https://www.somtribune.com/wp-content/uploads/2022/08/Photo-Resizer-2022_08_23_12_55_43-218x150.png"  width="218" height="150" /></a></div>                <a href="https://www.somtribune.com/category/worldinternational/politics/" class="td-post-category">Politics/Diplomacy</a>            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.somtribune.com/2022/08/23/somaliland-can-help-the-united-states-win-the-new-cold-war/" rel="bookmark" title="Somaliland Can Help The United States Win The New Cold War">Somaliland Can Help The United States Win The New Cold War</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.somtribune.com/2022/08/19/somaliland-mourns-death-of-greatest-of-contemporary-somali-poets-hadraawi/" rel="bookmark" class="td-image-wrap " title="Somaliland Mourns Death of Greatest of Contemporary Somali Poets &#8211; Hadraawi" ><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="Somaliland Mourns Death of Greatest of Contemporary Somali Poets &#8211; Hadraawi" data-type="image_tag" data-img-url="https://www.somtribune.com/wp-content/uploads/2022/08/Hadrawi-Umbrella1-218x150.png"  width="218" height="150" /></a></div>                <a href="https://www.somtribune.com/category/culture/artliterature/" class="td-post-category">Art/Literature</a>            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.somtribune.com/2022/08/19/somaliland-mourns-death-of-greatest-of-contemporary-somali-poets-hadraawi/" rel="bookmark" title="Somaliland Mourns Death of Greatest of Contemporary Somali Poets &#8211; Hadraawi">Somaliland Mourns Death of Greatest of Contemporary Somali Poets &#8211; Hadraawi</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.somtribune.com/2022/08/19/somaliland-modern-day-shakespeare-mohamed-i-warsame-hadrawi-the-man-and-the-poet-a-review/" rel="bookmark" class="td-image-wrap " title="Somaliland: Modern Day Shakespeare, Mohamed I Warsame Hadrawi: The Man and the Poet &#8211; A Review" ><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="Somaliland: Modern Day Shakespeare, Mohamed I Warsame Hadrawi: The Man and the Poet &#8211; A Review" data-type="image_tag" data-img-url="https://www.somtribune.com/wp-content/uploads/2022/08/Hadrawi1-218x150.jpg"  width="218" height="150" /></a></div>                <a href="https://www.somtribune.com/category/culture/artliterature/" class="td-post-category">Art/Literature</a>            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.somtribune.com/2022/08/19/somaliland-modern-day-shakespeare-mohamed-i-warsame-hadrawi-the-man-and-the-poet-a-review/" rel="bookmark" title="Somaliland: Modern Day Shakespeare, Mohamed I Warsame Hadrawi: The Man and the Poet &#8211; A Review">Somaliland: Modern Day Shakespeare, Mohamed I Warsame Hadrawi: The Man and&#8230;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.somtribune.com/2022/08/19/suhura-ismail-the-entrepreneur-khat-crowned-queen/" rel="bookmark" class="td-image-wrap " title="Suhura Ismail &#8211; the Entrepreneur Khat Crowned Queen" ><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="Suhura Ismail &#8211; the Entrepreneur Khat Crowned Queen" data-type="image_tag" data-img-url="https://www.somtribune.com/wp-content/uploads/2022/07/Suhura-Ismail-218x150.jpeg"  width="218" height="150" /></a></div>                <a href="https://www.somtribune.com/category/worldinternational/africa/" class="td-post-category">Africa</a>            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.somtribune.com/2022/08/19/suhura-ismail-the-entrepreneur-khat-crowned-queen/" rel="bookmark" title="Suhura Ismail &#8211; the Entrepreneur Khat Crowned Queen">Suhura Ismail &#8211; the Entrepreneur Khat Crowned Queen</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.somtribune.com/2022/08/18/somaliland-advisory-group-urge-political-stakeholders-to-engage-in-substantive-dialogue/" rel="bookmark" class="td-image-wrap " title="Somaliland Advisory Group Urge Political Stakeholders to Engage in Substantive Dialogue" ><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="Somaliland Advisory Group Urge Political Stakeholders to Engage in Substantive Dialogue" data-type="image_tag" data-img-url="https://www.somtribune.com/wp-content/uploads/2022/08/Somaliland-First-1-218x150.jpg"  width="218" height="150" /></a></div>                <a href="https://www.somtribune.com/category/worldinternational/politics/" class="td-post-category">Politics/Diplomacy</a>            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.somtribune.com/2022/08/18/somaliland-advisory-group-urge-political-stakeholders-to-engage-in-substantive-dialogue/" rel="bookmark" title="Somaliland Advisory Group Urge Political Stakeholders to Engage in Substantive Dialogue">Somaliland Advisory Group Urge Political Stakeholders to Engage in Substantive Dialogue</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" aria-label="prev-page" id="prev-page-tdi_1" data-td_block_id="tdi_1"><i class="td-next-prev-icon td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" aria-label="next-page" id="next-page-tdi_1" data-td_block_id="tdi_1"><i class="td-next-prev-icon td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-24"><a href="https://www.somtribune.com/category/somaliland/">Somaliland</a>
	<ul class="sub-menu">
		<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu tdi_2 td-no-subcats td_with_ajax_pagination td-pb-border-top td_block_template_1 td_ajax_preloading_preload"  data-td-block-uid="tdi_2" ><script>var block_tdi_2 = new tdBlock();
block_tdi_2.id = "tdi_2";
block_tdi_2.atts = '{"limit":"5","td_column_number":3,"ajax_pagination":"next_prev","category_id":"2","show_child_cat":30,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"preload","block_type":"td_block_mega_menu","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"tdi_2","tdc_css_class":"tdi_2","tdc_css_class_style":"tdi_2_rand_style"}';
block_tdi_2.td_column_number = "3";
block_tdi_2.block_type = "td_block_mega_menu";
block_tdi_2.post_count = "5";
block_tdi_2.found_posts = "3196";
block_tdi_2.header_color = "";
block_tdi_2.ajax_pagination_infinite_stop = "";
block_tdi_2.max_num_pages = "640";
tdBlocksArray.push(block_tdi_2);
</script><div id=tdi_2 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.somtribune.com/2022/08/23/somaliland-can-help-the-united-states-win-the-new-cold-war/" rel="bookmark" class="td-image-wrap " title="Somaliland Can Help The United States Win The New Cold War" ><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="Somaliland Can Help The United States Win The New Cold War" data-type="image_tag" data-img-url="https://www.somtribune.com/wp-content/uploads/2022/08/Photo-Resizer-2022_08_23_12_55_43-218x150.png"  width="218" height="150" /></a></div>                <a href="https://www.somtribune.com/category/worldinternational/politics/" class="td-post-category">Politics/Diplomacy</a>            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.somtribune.com/2022/08/23/somaliland-can-help-the-united-states-win-the-new-cold-war/" rel="bookmark" title="Somaliland Can Help The United States Win The New Cold War">Somaliland Can Help The United States Win The New Cold War</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.somtribune.com/2022/08/19/somaliland-mourns-death-of-greatest-of-contemporary-somali-poets-hadraawi/" rel="bookmark" class="td-image-wrap " title="Somaliland Mourns Death of Greatest of Contemporary Somali Poets &#8211; Hadraawi" ><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="Somaliland Mourns Death of Greatest of Contemporary Somali Poets &#8211; Hadraawi" data-type="image_tag" data-img-url="https://www.somtribune.com/wp-content/uploads/2022/08/Hadrawi-Umbrella1-218x150.png"  width="218" height="150" /></a></div>                <a href="https://www.somtribune.com/category/culture/artliterature/" class="td-post-category">Art/Literature</a>            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.somtribune.com/2022/08/19/somaliland-mourns-death-of-greatest-of-contemporary-somali-poets-hadraawi/" rel="bookmark" title="Somaliland Mourns Death of Greatest of Contemporary Somali Poets &#8211; Hadraawi">Somaliland Mourns Death of Greatest of Contemporary Somali Poets &#8211; Hadraawi</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.somtribune.com/2022/08/19/somaliland-modern-day-shakespeare-mohamed-i-warsame-hadrawi-the-man-and-the-poet-a-review/" rel="bookmark" class="td-image-wrap " title="Somaliland: Modern Day Shakespeare, Mohamed I Warsame Hadrawi: The Man and the Poet &#8211; A Review" ><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="Somaliland: Modern Day Shakespeare, Mohamed I Warsame Hadrawi: The Man and the Poet &#8211; A Review" data-type="image_tag" data-img-url="https://www.somtribune.com/wp-content/uploads/2022/08/Hadrawi1-218x150.jpg"  width="218" height="150" /></a></div>                <a href="https://www.somtribune.com/category/culture/artliterature/" class="td-post-category">Art/Literature</a>            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.somtribune.com/2022/08/19/somaliland-modern-day-shakespeare-mohamed-i-warsame-hadrawi-the-man-and-the-poet-a-review/" rel="bookmark" title="Somaliland: Modern Day Shakespeare, Mohamed I Warsame Hadrawi: The Man and the Poet &#8211; A Review">Somaliland: Modern Day Shakespeare, Mohamed I Warsame Hadrawi: The Man and&#8230;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.somtribune.com/2022/08/19/suhura-ismail-the-entrepreneur-khat-crowned-queen/" rel="bookmark" class="td-image-wrap " title="Suhura Ismail &#8211; the Entrepreneur Khat Crowned Queen" ><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="Suhura Ismail &#8211; the Entrepreneur Khat Crowned Queen" data-type="image_tag" data-img-url="https://www.somtribune.com/wp-content/uploads/2022/07/Suhura-Ismail-218x150.jpeg"  width="218" height="150" /></a></div>                <a href="https://www.somtribune.com/category/worldinternational/africa/" class="td-post-category">Africa</a>            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.somtribune.com/2022/08/19/suhura-ismail-the-entrepreneur-khat-crowned-queen/" rel="bookmark" title="Suhura Ismail &#8211; the Entrepreneur Khat Crowned Queen">Suhura Ismail &#8211; the Entrepreneur Khat Crowned Queen</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.somtribune.com/2022/08/18/somaliland-advisory-group-urge-political-stakeholders-to-engage-in-substantive-dialogue/" rel="bookmark" class="td-image-wrap " title="Somaliland Advisory Group Urge Political Stakeholders to Engage in Substantive Dialogue" ><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="Somaliland Advisory Group Urge Political Stakeholders to Engage in Substantive Dialogue" data-type="image_tag" data-img-url="https://www.somtribune.com/wp-content/uploads/2022/08/Somaliland-First-1-218x150.jpg"  width="218" height="150" /></a></div>                <a href="https://www.somtribune.com/category/worldinternational/politics/" class="td-post-category">Politics/Diplomacy</a>            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.somtribune.com/2022/08/18/somaliland-advisory-group-urge-political-stakeholders-to-engage-in-substantive-dialogue/" rel="bookmark" title="Somaliland Advisory Group Urge Political Stakeholders to Engage in Substantive Dialogue">Somaliland Advisory Group Urge Political Stakeholders to Engage in Substantive Dialogue</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" aria-label="prev-page" id="prev-page-tdi_2" data-td_block_id="tdi_2"><i class="td-next-prev-icon td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" aria-label="next-page" id="next-page-tdi_2" data-td_block_id="tdi_2"><i class="td-next-prev-icon td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
	</ul>
</li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-23"><a href="https://www.somtribune.com/category/somalia/">Somalia</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor td-menu-item td-normal-menu menu-item-26"><a href="https://www.somtribune.com/category/worldinternational/">World News/International</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor td-menu-item td-normal-menu menu-item-18"><a href="https://www.somtribune.com/category/worldinternational/africa/">Africa</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-25"><a href="https://www.somtribune.com/category/sports/">Sports</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-19"><a href="https://www.somtribune.com/category/economy/">Economy/Business</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu tdi_3 td_with_ajax_pagination td-pb-border-top td_block_template_1 td_ajax_preloading_preload"  data-td-block-uid="tdi_3" ><script>var block_tdi_3 = new tdBlock();
block_tdi_3.id = "tdi_3";
block_tdi_3.atts = '{"limit":4,"td_column_number":3,"ajax_pagination":"next_prev","category_id":"7","show_child_cat":30,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"preload","block_type":"td_block_mega_menu","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"tdi_3","tdc_css_class":"tdi_3","tdc_css_class_style":"tdi_3_rand_style"}';
block_tdi_3.td_column_number = "3";
block_tdi_3.block_type = "td_block_mega_menu";
block_tdi_3.post_count = "4";
block_tdi_3.found_posts = "1281";
block_tdi_3.header_color = "";
block_tdi_3.ajax_pagination_infinite_stop = "";
block_tdi_3.max_num_pages = "321";
tdBlocksArray.push(block_tdi_3);
</script>            <script>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</script>
            <div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-tdi_3" id="tdi_4" data-td_block_id="tdi_3" data-td_filter_value="" href="https://www.somtribune.com/category/economy/">All</a><a class="mega-menu-sub-cat-tdi_3"  id="tdi_5" data-td_block_id="tdi_3" data-td_filter_value="905" href="https://www.somtribune.com/category/economy/finance/">Finance</a><a class="mega-menu-sub-cat-tdi_3"  id="tdi_6" data-td_block_id="tdi_3" data-td_filter_value="940" href="https://www.somtribune.com/category/economy/markets/">Markets</a></div></div><div id=tdi_3 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.somtribune.com/2022/08/19/suhura-ismail-the-entrepreneur-khat-crowned-queen/" rel="bookmark" class="td-image-wrap " title="Suhura Ismail &#8211; the Entrepreneur Khat Crowned Queen" ><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="Suhura Ismail &#8211; the Entrepreneur Khat Crowned Queen" data-type="image_tag" data-img-url="https://www.somtribune.com/wp-content/uploads/2022/07/Suhura-Ismail-218x150.jpeg"  width="218" height="150" /></a></div>                <a href="https://www.somtribune.com/category/worldinternational/africa/" class="td-post-category">Africa</a>            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.somtribune.com/2022/08/19/suhura-ismail-the-entrepreneur-khat-crowned-queen/" rel="bookmark" title="Suhura Ismail &#8211; the Entrepreneur Khat Crowned Queen">Suhura Ismail &#8211; the Entrepreneur Khat Crowned Queen</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.somtribune.com/2022/08/16/first-post-blockade-food-aid-ship-leaves-ukraine-for-africa/" rel="bookmark" class="td-image-wrap " title="First Post-Blockade Food Aid Ship Leaves Ukraine for Africa" ><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="First Post-Blockade Food Aid Ship Leaves Ukraine for Africa" data-type="image_tag" data-img-url="https://www.somtribune.com/wp-content/uploads/2022/08/Wheat-218x150.jpg"  width="218" height="150" /></a></div>                <a href="https://www.somtribune.com/category/worldinternational/africa/" class="td-post-category">Africa</a>            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.somtribune.com/2022/08/16/first-post-blockade-food-aid-ship-leaves-ukraine-for-africa/" rel="bookmark" title="First Post-Blockade Food Aid Ship Leaves Ukraine for Africa">First Post-Blockade Food Aid Ship Leaves Ukraine for Africa</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.somtribune.com/2022/08/13/ethiopia-completes-third-filling-of-blue-nile-mega-dam/" rel="bookmark" class="td-image-wrap " title="Ethiopia Completes Third Filling of Blue Nile Mega Dam" ><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC"alt="" data-type="image_tag" data-img-url="https://www.somtribune.com/wp-content/plugins/td-composer/legacy/Newspaper/assets/images/no-thumb/td_218x150.png"  width="218" height="150" /><span class="td-video-play-ico"><i class="td-icon-video-thumb-play"></i></span></a></div>                <a href="https://www.somtribune.com/category/economy/" class="td-post-category">Economy/Business</a>            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.somtribune.com/2022/08/13/ethiopia-completes-third-filling-of-blue-nile-mega-dam/" rel="bookmark" title="Ethiopia Completes Third Filling of Blue Nile Mega Dam">Ethiopia Completes Third Filling of Blue Nile Mega Dam</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.somtribune.com/2022/08/09/uganda-somalia-stage-business-summit-in-kampala/" rel="bookmark" class="td-image-wrap " title="Uganda, Somalia Stage Business Summit in Kampala" ><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="Uganda, Somalia Stage Business Summit in Kampala" data-type="image_tag" data-img-url="https://www.somtribune.com/wp-content/uploads/2022/08/Info--218x150.jpeg"  width="218" height="150" /></a></div>                <a href="https://www.somtribune.com/category/worldinternational/africa/" class="td-post-category">Africa</a>            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.somtribune.com/2022/08/09/uganda-somalia-stage-business-summit-in-kampala/" rel="bookmark" title="Uganda, Somalia Stage Business Summit in Kampala">Uganda, Somalia Stage Business Summit in Kampala</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" aria-label="prev-page" id="prev-page-tdi_3" data-td_block_id="tdi_3"><i class="td-next-prev-icon td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" aria-label="next-page" id="next-page-tdi_3" data-td_block_id="tdi_3"><i class="td-next-prev-icon td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-21"><a href="https://www.somtribune.com/category/editorial/">Editorial</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu tdi_7 td-no-subcats td_with_ajax_pagination td-pb-border-top td_block_template_1 td_ajax_preloading_preload"  data-td-block-uid="tdi_7" ><script>var block_tdi_7 = new tdBlock();
block_tdi_7.id = "tdi_7";
block_tdi_7.atts = '{"limit":"5","td_column_number":3,"ajax_pagination":"next_prev","category_id":"10","show_child_cat":30,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"preload","block_type":"td_block_mega_menu","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"tdi_7","tdc_css_class":"tdi_7","tdc_css_class_style":"tdi_7_rand_style"}';
block_tdi_7.td_column_number = "3";
block_tdi_7.block_type = "td_block_mega_menu";
block_tdi_7.post_count = "5";
block_tdi_7.found_posts = "29";
block_tdi_7.header_color = "";
block_tdi_7.ajax_pagination_infinite_stop = "";
block_tdi_7.max_num_pages = "6";
tdBlocksArray.push(block_tdi_7);
</script><div id=tdi_7 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.somtribune.com/2021/02/25/partners-call-somalia-government-fms-to-agree-on-crucial-issues-including-non-member-somaliland-mps/" rel="bookmark" class="td-image-wrap " title="Partners Call Somalia Government, FMS to Agree on Crucial Issues Including Non-member Somaliland MPs" ><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="Partners Call Somalia Government, FMS to Agree on Crucial Issues Including Non-member Somaliland MPs" data-type="image_tag" data-img-url="https://www.somtribune.com/wp-content/uploads/2021/02/Somalia-Partners-VS-Somaliland-218x150.jpg"  width="218" height="150" /></a></div>                <a href="https://www.somtribune.com/category/editorial/" class="td-post-category">Editorial</a>            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.somtribune.com/2021/02/25/partners-call-somalia-government-fms-to-agree-on-crucial-issues-including-non-member-somaliland-mps/" rel="bookmark" title="Partners Call Somalia Government, FMS to Agree on Crucial Issues Including Non-member Somaliland MPs">Partners Call Somalia Government, FMS to Agree on Crucial Issues Including&#8230;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.somtribune.com/2020/05/18/somaliland-is-covid-19-wholly-responsible-for-a-dead-29th-18-may-anniversary-festive-mood/" rel="bookmark" class="td-image-wrap " title="Somaliland: Is COVID-19 Wholly Responsible for a Dead 29th 18 May Anniversary Festive Mood?" ><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="Somaliland: Is COVID-19 Wholly Responsible for a Dead 29th 18 May Anniversary Festive Mood?" data-type="image_tag" data-img-url="https://www.somtribune.com/wp-content/uploads/2020/05/Somaliland-Map-218x150.jpeg"  width="218" height="150" /></a></div>                <a href="https://www.somtribune.com/category/editorial/" class="td-post-category">Editorial</a>            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.somtribune.com/2020/05/18/somaliland-is-covid-19-wholly-responsible-for-a-dead-29th-18-may-anniversary-festive-mood/" rel="bookmark" title="Somaliland: Is COVID-19 Wholly Responsible for a Dead 29th 18 May Anniversary Festive Mood?">Somaliland: Is COVID-19 Wholly Responsible for a Dead 29th 18 May&#8230;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.somtribune.com/2020/05/07/somalia-openly-portrays-somaliland-as-a-federal-entity-for-1st-time/" rel="bookmark" class="td-image-wrap " title="Somalia Openly Portrays Somaliland as a Federal Entity for 1st Time" ><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="Somalia Openly Portrays Somaliland as a Federal Entity for 1st Time" data-type="image_tag" data-img-url="https://www.somtribune.com/wp-content/uploads/2020/05/DF-218x150.jpg"  width="218" height="150" /></a></div>                <a href="https://www.somtribune.com/category/editorial/" class="td-post-category">Editorial</a>            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.somtribune.com/2020/05/07/somalia-openly-portrays-somaliland-as-a-federal-entity-for-1st-time/" rel="bookmark" title="Somalia Openly Portrays Somaliland as a Federal Entity for 1st Time">Somalia Openly Portrays Somaliland as a Federal Entity for 1st Time</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.somtribune.com/2020/02/21/somaliland-is-renewed-ethio-somalia-relations-bringing-the-zeila-equation-back-into-focus/" rel="bookmark" class="td-image-wrap " title="Somaliland: Is Renewed Ethio-Somalia Relations Bringing The Zeila Equation Back Into Focus?" ><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="Somaliland: Is Renewed Ethio-Somalia Relations Bringing The Zeila Equation Back Into Focus?" data-type="image_tag" data-img-url="https://www.somtribune.com/wp-content/uploads/2020/02/Screen-Shot-2020-02-21-at-10.47.18-PM-218x150.png"  width="218" height="150" /></a></div>                <a href="https://www.somtribune.com/category/editorial/" class="td-post-category">Editorial</a>            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.somtribune.com/2020/02/21/somaliland-is-renewed-ethio-somalia-relations-bringing-the-zeila-equation-back-into-focus/" rel="bookmark" title="Somaliland: Is Renewed Ethio-Somalia Relations Bringing The Zeila Equation Back Into Focus?">Somaliland: Is Renewed Ethio-Somalia Relations Bringing The Zeila Equation Back Into&#8230;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.somtribune.com/2020/02/13/farmajo-compounds-somalia-genocide-against-somaliland-with-jesting-apology/" rel="bookmark" class="td-image-wrap " title="Farmajo Compounds Somalia Genocide Against Somaliland With Jesting &#8216;Apology&#8217;" ><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="Farmajo Compounds Somalia Genocide Against Somaliland With Jesting &#8216;Apology&#8217;" data-type="image_tag" data-img-url="https://www.somtribune.com/wp-content/uploads/2020/02/maxresdefault-5-218x150.jpg"  width="218" height="150" /><span class="td-video-play-ico"><i class="td-icon-video-thumb-play"></i></span></a></div>                <a href="https://www.somtribune.com/category/editorial/" class="td-post-category">Editorial</a>            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.somtribune.com/2020/02/13/farmajo-compounds-somalia-genocide-against-somaliland-with-jesting-apology/" rel="bookmark" title="Farmajo Compounds Somalia Genocide Against Somaliland With Jesting &#8216;Apology&#8217;">Farmajo Compounds Somalia Genocide Against Somaliland With Jesting &#8216;Apology&#8217;</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" aria-label="prev-page" id="prev-page-tdi_7" data-td_block_id="tdi_7"><i class="td-next-prev-icon td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" aria-label="next-page" id="next-page-tdi_7" data-td_block_id="tdi_7"><i class="td-next-prev-icon td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-22"><a href="https://www.somtribune.com/category/opinionanalysis/">Opinion/Analysis</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu tdi_8 td-no-subcats td_with_ajax_pagination td-pb-border-top td_block_template_1 td_ajax_preloading_preload"  data-td-block-uid="tdi_8" ><script>var block_tdi_8 = new tdBlock();
block_tdi_8.id = "tdi_8";
block_tdi_8.atts = '{"limit":"5","td_column_number":3,"ajax_pagination":"next_prev","category_id":"4","show_child_cat":30,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"preload","block_type":"td_block_mega_menu","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"tdi_8","tdc_css_class":"tdi_8","tdc_css_class_style":"tdi_8_rand_style"}';
block_tdi_8.td_column_number = "3";
block_tdi_8.block_type = "td_block_mega_menu";
block_tdi_8.post_count = "5";
block_tdi_8.found_posts = "537";
block_tdi_8.header_color = "";
block_tdi_8.ajax_pagination_infinite_stop = "";
block_tdi_8.max_num_pages = "108";
tdBlocksArray.push(block_tdi_8);
</script><div id=tdi_8 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.somtribune.com/2022/08/18/remembering-hadrawi-my-teacher-mentor-and-friend/" rel="bookmark" class="td-image-wrap " title="Remembering Hadrawi: My Teacher, Mentor and Friend" ><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="Remembering Hadrawi: My Teacher, Mentor and Friend" data-type="image_tag" data-img-url="https://www.somtribune.com/wp-content/uploads/2022/08/Abu-Hadra-210x150.jpeg"  width="210" height="150" /></a></div>                <a href="https://www.somtribune.com/category/culture/artliterature/" class="td-post-category">Art/Literature</a>            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.somtribune.com/2022/08/18/remembering-hadrawi-my-teacher-mentor-and-friend/" rel="bookmark" title="Remembering Hadrawi: My Teacher, Mentor and Friend">Remembering Hadrawi: My Teacher, Mentor and Friend</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.somtribune.com/2022/08/16/more-chinese-military-bases-in-africa-a-question-of-when-not-if/" rel="bookmark" class="td-image-wrap " title="More Chinese Military Bases in Africa: A Question of When, Not If" ><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="More Chinese Military Bases in Africa: A Question of When, Not If" data-type="image_tag" data-img-url="https://www.somtribune.com/wp-content/uploads/2022/08/Chinese-bases-218x150.jpg"  width="218" height="150" /></a></div>                <a href="https://www.somtribune.com/category/worldinternational/africa/" class="td-post-category">Africa</a>            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.somtribune.com/2022/08/16/more-chinese-military-bases-in-africa-a-question-of-when-not-if/" rel="bookmark" title="More Chinese Military Bases in Africa: A Question of When, Not If">More Chinese Military Bases in Africa: A Question of When, Not&#8230;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.somtribune.com/2022/06/30/i-saw-prince-charles-inspire-hope-at-the-commonwealth-summit-nimco-ali/" rel="bookmark" class="td-image-wrap " title="I saw Prince Charles Inspire Hope at the Commonwealth Summit &#8211; Nimco Ali" ><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="I saw Prince Charles Inspire Hope at the Commonwealth Summit &#8211; Nimco Ali" data-type="image_tag" data-img-url="https://www.somtribune.com/wp-content/uploads/2022/06/Nimco-Ali-218x150.jpg"  width="218" height="150" /></a></div>                <a href="https://www.somtribune.com/category/opinionanalysis/" class="td-post-category">Opinion/Analysis</a>            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.somtribune.com/2022/06/30/i-saw-prince-charles-inspire-hope-at-the-commonwealth-summit-nimco-ali/" rel="bookmark" title="I saw Prince Charles Inspire Hope at the Commonwealth Summit &#8211; Nimco Ali">I saw Prince Charles Inspire Hope at the Commonwealth Summit &#8211;&#8230;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.somtribune.com/2022/06/25/it-may-be-too-late-to-save-america/" rel="bookmark" class="td-image-wrap " title="It May Be Too Late to Save America" ><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="It May Be Too Late to Save America" data-type="image_tag" data-img-url="https://www.somtribune.com/wp-content/uploads/2022/06/demonstrators-protest-front-scotus-218x150.webp"  width="218" height="150" /></a></div>                <a href="https://www.somtribune.com/category/opinionanalysis/" class="td-post-category">Opinion/Analysis</a>            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.somtribune.com/2022/06/25/it-may-be-too-late-to-save-america/" rel="bookmark" title="It May Be Too Late to Save America">It May Be Too Late to Save America</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.somtribune.com/2022/06/04/somaliland-berbera-port-shows-true-value-of-doing-over-dithering/" rel="bookmark" class="td-image-wrap " title="Somaliland: Berbera Port Shows True Value of Doing Over Dithering" ><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="Somaliland: Berbera Port Shows True Value of Doing Over Dithering" data-type="image_tag" data-img-url="https://www.somtribune.com/wp-content/uploads/2022/06/John-Steenhuisen-218x150.jpg"  width="218" height="150" /></a></div>                <a href="https://www.somtribune.com/category/economy/" class="td-post-category">Economy/Business</a>            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.somtribune.com/2022/06/04/somaliland-berbera-port-shows-true-value-of-doing-over-dithering/" rel="bookmark" title="Somaliland: Berbera Port Shows True Value of Doing Over Dithering">Somaliland: Berbera Port Shows True Value of Doing Over Dithering</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" aria-label="prev-page" id="prev-page-tdi_8" data-td_block_id="tdi_8"><i class="td-next-prev-icon td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" aria-label="next-page" id="next-page-tdi_8" data-td_block_id="tdi_8"><i class="td-next-prev-icon td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-post_format td-menu-item td-mega-menu menu-item-40667"><a href="https://www.somtribune.com/type/video/">Videos</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu tdi_9 td-no-subcats td_with_ajax_pagination td-pb-border-top td_block_template_1 td_ajax_preloading_preload"  data-td-block-uid="tdi_9" ><script>var block_tdi_9 = new tdBlock();
block_tdi_9.id = "tdi_9";
block_tdi_9.atts = '{"limit":"5","td_column_number":3,"ajax_pagination":"next_prev","category_id":"9155","show_child_cat":30,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"preload","block_type":"td_block_mega_menu","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"tdi_9","tdc_css_class":"tdi_9","tdc_css_class_style":"tdi_9_rand_style"}';
block_tdi_9.td_column_number = "3";
block_tdi_9.block_type = "td_block_mega_menu";
block_tdi_9.post_count = "5";
block_tdi_9.found_posts = "13";
block_tdi_9.header_color = "";
block_tdi_9.ajax_pagination_infinite_stop = "";
block_tdi_9.max_num_pages = "3";
tdBlocksArray.push(block_tdi_9);
</script><div id=tdi_9 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.somtribune.com/2020/09/23/chevening-program-trains-leaders-of-tomorrow-uk-representative-in-somaliland-republic/" rel="bookmark" class="td-image-wrap " title="Chevening Program Trains Leaders of Tomorrow &#8211; UK Representative in Somaliland Republic" ><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC"alt="" data-type="image_tag" data-img-url="https://www.somtribune.com/wp-content/plugins/td-composer/legacy/Newspaper/assets/images/no-thumb/td_218x150.png"  width="218" height="150" /><span class="td-video-play-ico"><i class="td-icon-video-thumb-play"></i></span></a></div>                <a href="https://www.somtribune.com/category/social-issues/education/" class="td-post-category">Education</a>            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.somtribune.com/2020/09/23/chevening-program-trains-leaders-of-tomorrow-uk-representative-in-somaliland-republic/" rel="bookmark" title="Chevening Program Trains Leaders of Tomorrow &#8211; UK Representative in Somaliland Republic">Chevening Program Trains Leaders of Tomorrow &#8211; UK Representative in Somaliland&#8230;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.somtribune.com/2020/05/25/somaliland-general-foohle-laid-to-rest-in-state-funeral/" rel="bookmark" class="td-image-wrap " title="Somaliland: General Foohle laid to Rest in State Funeral" ><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="Somaliland: General Foohle laid to Rest in State Funeral" data-type="image_tag" data-img-url="https://www.somtribune.com/wp-content/uploads/2020/05/sddefault-3-218x150.jpg"  width="218" height="150" /><span class="td-video-play-ico"><i class="td-icon-video-thumb-play"></i></span></a></div>                <a href="https://www.somtribune.com/category/somaliland/" class="td-post-category">Somaliland</a>            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.somtribune.com/2020/05/25/somaliland-general-foohle-laid-to-rest-in-state-funeral/" rel="bookmark" title="Somaliland: General Foohle laid to Rest in State Funeral">Somaliland: General Foohle laid to Rest in State Funeral</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.somtribune.com/2020/05/25/somaliland-covid-19-update-for-may-25/" rel="bookmark" class="td-image-wrap " title="Somaliland COVID-19 Update for May 25" ><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="Somaliland COVID-19 Update for May 25" data-type="image_tag" data-img-url="https://www.somtribune.com/wp-content/uploads/2020/05/maxresdefault-5-218x150.jpg"  width="218" height="150" /><span class="td-video-play-ico"><i class="td-icon-video-thumb-play"></i></span></a></div>                <a href="https://www.somtribune.com/category/social-issues/health/" class="td-post-category">Health</a>            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.somtribune.com/2020/05/25/somaliland-covid-19-update-for-may-25/" rel="bookmark" title="Somaliland COVID-19 Update for May 25">Somaliland COVID-19 Update for May 25</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.somtribune.com/2020/01/11/somaliland-sizable-livestock-shipment-to-leave-for-the-uae-sunday/" rel="bookmark" class="td-image-wrap " title="Somaliland: Sizable Livestock Shipment to Leave for the UAE Sunday" ><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="Somaliland: Sizable Livestock Shipment to Leave for the UAE Sunday" data-type="image_tag" data-img-url="https://www.somtribune.com/wp-content/uploads/2020/01/maxresdefault-1-218x150.jpg"  width="218" height="150" /><span class="td-video-play-ico"><i class="td-icon-video-thumb-play"></i></span></a></div>                <a href="https://www.somtribune.com/category/economy/" class="td-post-category">Economy/Business</a>            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.somtribune.com/2020/01/11/somaliland-sizable-livestock-shipment-to-leave-for-the-uae-sunday/" rel="bookmark" title="Somaliland: Sizable Livestock Shipment to Leave for the UAE Sunday">Somaliland: Sizable Livestock Shipment to Leave for the UAE Sunday</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.somtribune.com/2019/03/16/new-zealand-killer-had-trump-in-his-manifesto/" rel="bookmark" class="td-image-wrap " title="New Zealand Killer Had Trump in his Manifesto" ><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="New Zealand Killer Had Trump in his Manifesto" data-type="image_tag" data-img-url="https://www.somtribune.com/wp-content/uploads/2019/03/Manifesto-218x150.jpg"  width="218" height="150" /><span class="td-video-play-ico"><i class="td-icon-video-thumb-play"></i></span></a></div>                <a href="https://www.somtribune.com/category/worldinternational/crime-safety/" class="td-post-category">Conflict/Crime</a>            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.somtribune.com/2019/03/16/new-zealand-killer-had-trump-in-his-manifesto/" rel="bookmark" title="New Zealand Killer Had Trump in his Manifesto">New Zealand Killer Had Trump in his Manifesto</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" aria-label="prev-page" id="prev-page-tdi_9" data-td_block_id="tdi_9"><i class="td-next-prev-icon td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" aria-label="next-page" id="next-page-tdi_9" data-td_block_id="tdi_9"><i class="td-next-prev-icon td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-1087"><a href="https://www.somtribune.com/contact-us/">Contact Us</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-64392"><a href="https://www.somtribune.com/category/featured/">Featured</a></li>
</ul></div></div>
            </div>
        </div>
    </div>

            <div class="td-banner-wrap-full td-container-wrap ">
            <div class="td-container-header td-header-row td-header-header">
                <div class="td-header-sp-recs">
                    <div class="td-header-rec-wrap">
    
 <!-- A generated by theme --> 

<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><div class="td-g-rec td-g-rec-id-header tdi_10 td_block_template_1 ">

<style>
/* custom css */
.tdi_10.td-a-rec{
					text-align: center;
				}.tdi_10 .td-element-style{
					z-index: -1;
				}.tdi_10.td-a-rec-img{
				    text-align: left;
				}.tdi_10.td-a-rec-img img{
                    margin: 0 auto 0 0;
                }@media (max-width: 767px) {
				    .tdi_10.td-a-rec-img {
				        text-align: center;
				    }
                }
</style><script type="text/javascript">
var td_screen_width = window.innerWidth;
window.addEventListener("load", function(){            
	            var placeAdEl = document.getElementById("td-ad-placeholder");
			    if ( null !== placeAdEl && td_screen_width >= 1140 ) {
			        
			        /* large monitors */
			        var adEl = document.createElement("ins");
		            placeAdEl.replaceWith(adEl);	
		            adEl.setAttribute("class", "adsbygoogle");
		            adEl.setAttribute("style", "display:inline-block;width:728px;height:90px");	            		                
		            adEl.setAttribute("data-ad-client", "ca-pub-2555703565567078");
		            adEl.setAttribute("data-ad-slot", "");	            
			        (adsbygoogle = window.adsbygoogle || []).push({});
			    }
			});window.addEventListener("load", function(){            
	            var placeAdEl = document.getElementById("td-ad-placeholder");
			    if ( null !== placeAdEl && td_screen_width >= 1019  && td_screen_width < 1140 ) {
			    
			        /* landscape tablets */
			        var adEl = document.createElement("ins");
		            placeAdEl.replaceWith(adEl);	
		            adEl.setAttribute("class", "adsbygoogle");
		            adEl.setAttribute("style", "display:inline-block;width:468px;height:60px");	            		                
		            adEl.setAttribute("data-ad-client", "ca-pub-2555703565567078");
		            adEl.setAttribute("data-ad-slot", "");	            
			        (adsbygoogle = window.adsbygoogle || []).push({});
			    }
			});window.addEventListener("load", function(){            
	            var placeAdEl = document.getElementById("td-ad-placeholder");
			    if ( null !== placeAdEl && td_screen_width >= 768  && td_screen_width < 1019 ) {
			    
			        /* portrait tablets */
			        var adEl = document.createElement("ins");
		            placeAdEl.replaceWith(adEl);	
		            adEl.setAttribute("class", "adsbygoogle");
		            adEl.setAttribute("style", "display:inline-block;width:468px;height:60px");	            		                
		            adEl.setAttribute("data-ad-client", "ca-pub-2555703565567078");
		            adEl.setAttribute("data-ad-slot", "");	            
			        (adsbygoogle = window.adsbygoogle || []).push({});
			    }
			});window.addEventListener("load", function(){            
	            var placeAdEl = document.getElementById("td-ad-placeholder");
			    if ( null !== placeAdEl && td_screen_width < 768 ) {
			    
			        /* Phones */
			        var adEl = document.createElement("ins");
		            placeAdEl.replaceWith(adEl);	
		            adEl.setAttribute("class", "adsbygoogle");
		            adEl.setAttribute("style", "display:inline-block;width:320px;height:50px");	            		                
		            adEl.setAttribute("data-ad-client", "ca-pub-2555703565567078");
		            adEl.setAttribute("data-ad-slot", "");	            
			        (adsbygoogle = window.adsbygoogle || []).push({});
			    }
			});</script>
<noscript id="td-ad-placeholder"></noscript></div>

 <!-- end A --> 


</div>                </div>
            </div>
        </div>
    </div>
            </div>

            
<div class="td-main-content-wrap td-container-wrap">

    <div class="td-container td-post-template-2">
        <article id="post-64460" class="post-64460 post type-post status-publish format-standard has-post-thumbnail hentry category-kenya category-law category-politics tag-iebc tag-kenya tag-kenya-elections tag-law-and-order" itemscope itemtype="https://schema.org/Article">
            <div class="td-pb-row">
                <div class="td-pb-span12">
                    <div class="td-post-header">
                        <div class="td-crumb-container"><div class="entry-crumbs"><span><a title="" class="entry-crumb" href="https://www.somtribune.com/">Home</a></span> <i class="td-icon-right td-bread-sep"></i> <span><a title="View all posts in Africa" class="entry-crumb" href="https://www.somtribune.com/category/worldinternational/africa/">Africa</a></span> <i class="td-icon-right td-bread-sep"></i> <span><a title="View all posts in Kenya" class="entry-crumb" href="https://www.somtribune.com/category/worldinternational/africa/kenya/">Kenya</a></span> <i class="td-icon-right td-bread-sep td-bred-no-url-last"></i> <span class="td-bred-no-url-last">Kenya: Hooligans Attempt to Harm IEBC Officials</span></div></div>

                        <ul class="td-category"><li class="entry-category"><a  href="https://www.somtribune.com/category/worldinternational/africa/">Africa</a></li><li class="entry-category"><a  href="https://www.somtribune.com/category/worldinternational/africa/kenya/">Kenya</a></li><li class="entry-category"><a  href="https://www.somtribune.com/category/law/">Law &amp; Order</a></li><li class="entry-category"><a  href="https://www.somtribune.com/category/worldinternational/">World News/International</a></li><li class="entry-category"><a  href="https://www.somtribune.com/category/worldinternational/politics/">Politics/Diplomacy</a></li></ul>
                        <header class="td-post-title">
                            <h1 class="entry-title">Kenya: Hooligans Attempt to Harm IEBC Officials</h1>

                            

                            <div class="td-module-meta-info">
                                <div class="td-post-author-name"><div class="td-author-by">By</div> <a href="https://www.somtribune.com/author/news-desk/">News Desk</a><div class="td-author-line"> - </div> </div>                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2022-08-23T20:48:04+03:00" >August 23, 2022</time></span>                                                                                            </div>

                        </header>
                    </div>
                </div>
            </div> <!-- /.td-pb-row -->

            <div class="td-pb-row">
                                            <div class="td-pb-span8 td-main-content" role="main">
                                <div class="td-ss-main-content">
                                    
        <div class="td-post-sharing-top"><div id="td_social_sharing_article_top" class="td-post-sharing td-ps-bg td-ps-notext td-post-sharing-style1 ">
		<style>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</style>

		<div class="td-post-sharing-visible"><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.somtribune.com%2F2022%2F08%2F23%2Fkenya-hooligans-attempt-to-harm-iebc-officials%2F" title="Facebook" >
                                        <div class="td-social-but-icon"><i class="td-icon-facebook"></i></div>
                                        <div class="td-social-but-text">Facebook</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=Kenya%3A+Hooligans+Attempt+to+Harm+IEBC+Officials&url=https%3A%2F%2Fwww.somtribune.com%2F2022%2F08%2F23%2Fkenya-hooligans-attempt-to-harm-iebc-officials%2F&via=SomTribune" title="Twitter" >
                                        <div class="td-social-but-icon"><i class="td-icon-twitter"></i></div>
                                        <div class="td-social-but-text">Twitter</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-pinterest" href="https://pinterest.com/pin/create/button/?url=https://www.somtribune.com/2022/08/23/kenya-hooligans-attempt-to-harm-iebc-officials/&amp;media=https://www.somtribune.com/wp-content/uploads/2022/08/IEBC.jpg&description=Nairobi hotel when a group of about 50 people raided and attempted to attack Independent Electoral and Boundaries Commission (IEBC) personnel" title="Pinterest" >
                                        <div class="td-social-but-icon"><i class="td-icon-pinterest"></i></div>
                                        <div class="td-social-but-text">Pinterest</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-whatsapp" href="https://api.whatsapp.com/send?text=Kenya%3A+Hooligans+Attempt+to+Harm+IEBC+Officials %0A%0A https://www.somtribune.com/2022/08/23/kenya-hooligans-attempt-to-harm-iebc-officials/" title="WhatsApp" >
                                        <div class="td-social-but-icon"><i class="td-icon-whatsapp"></i></div>
                                        <div class="td-social-but-text">WhatsApp</div>
                                    </a></div><div class="td-social-sharing-hidden"><ul class="td-pulldown-filter-list"></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="td_social_sharing_article_top" title="More">
                                    <div class="td-social-but-icon"><i class="td-icon-plus td-social-expand-tabs-icon"></i></div>
                                </a></div></div></div>

        <div class="td-post-content tagdiv-type">
            <div class="td-post-featured-image"><a href="https://www.somtribune.com/wp-content/uploads/2022/08/IEBC.jpg" data-caption=""><img width="624" height="351" class="entry-thumb td-modal-image" src="https://www.somtribune.com/wp-content/uploads/2022/08/IEBC.jpg" srcset="https://www.somtribune.com/wp-content/uploads/2022/08/IEBC.jpg 624w, https://www.somtribune.com/wp-content/uploads/2022/08/IEBC-300x169.jpg 300w, https://www.somtribune.com/wp-content/uploads/2022/08/IEBC-150x84.jpg 150w" sizes="(max-width: 624px) 100vw, 624px" alt="" title="IEBC"/></a></div>
            <p>There was drama at a Nairobi hotel when a group of about 50 people raided and attempted to attack Independent Electoral and Boundaries Commission (IEBC) personnel.</p>
<p>The personnel were meeting at the Sarova Panafric Hotel along Valley Road when the group said to have been armed with crude weapons tried to force their way into their room.</p>
<p>The Commission said the attempt happened on Monday at around 8:30 pm and that the personnel were preparing responses for the filed presidential election petitions.</p>
<p>Witnesses said the group seemed to have been tipped off by a reveller who had spotted the officials there and mistook their meeting to be mischievous.</p>
<p>An alarm was raised and security responded before the group dispersed but left the personnel worried.</p>
<p>Some had arrived aboard motorcycles and others on private cars in a coordinated manner, witnesses said.</p>
<p>They noted that the group claimed the commission personnel were altering the IEBC portal.</p>
<p>“An organized group of goons wielding crude weapons attempted to attack IEBC personnel preparing responses to Presidential election petitions at a premise within Nairobi. However, they were repulsed by Security,” the Commission said.</p>
<p>An IEBC official present and security at the facility called Inspector General of Police Hilary Mutyambai to ensure that its personnel are protected.</p>
<p>“The Commission condemns this act of hooliganism and intimidation, and calls upon the Inspector of Police (IG) to bring to an end this blatant abuse of the Rule of Law.”</p>
<p>More than 50-armed police officers were later deployed at the facility to man it until the end of the petition.</p>
<p>Mutyambai said they are determined to ensure security for all amid protests from the commission on their safety at large after the elections.</p>
<p>The IEBC personnel are meeting there to respond to the presidential petitions so far filed.</p>
<p>On Monday, the Supreme Court received nine petitions. The commission is rushing against time to respond to the petitions.</p>
<p>In a notice, Chief Justice Martha Koome indicated that any election petition should be filed within seven days from the date IEBC will declare the results.</p>
<p>“The Supreme Court of Kenya is established under Article 163 of the Constitution and is at the apex of the Judiciary with the final authority in arbitration of disputes. Judicial authority is derived from the people and exercised in accordance with the cardinal principles spelt out in Article 159(2) of the Constitution. One of the key principles of administration of justice is that justice shall not be delayed,” the notice.</p>
<p>The Judiciary said petitioners will have 24 hours to serve respondents from the time of filing the petition.</p>
<p>Upon being served, respondents will have four days to respond to the issues raised and serve the petitioner with their response.</p>
<p>Thereafter the Supreme Court will hold the pre-trial conference eight days after the filing of the petition and immediately thereafter start hearing the petition and render its decision within 14 days.</p>
<p>The seven judges expected to hear the election dispute are Chief Justice Martha Koome, Deputy Chief Justice Philomena Mwilu and judges Isaac Lenaola, Njoki Ndung’u, Smokin Wanjala, William Ouko and Mohamed Ibrahim.</p>
<p>Justice Koome and Supreme Court Judge William Ouko have never handled a presidential election dispute since they were appointed to the Apex court last year.</p>
<p>Mwilu and Justices Lenaola and Wanjala were part of the Bench that nullified President Uhuru Kenyatta’s win in 2017.</p>
<p>Source: <em>The Star</em></p>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-64460" class="share-twitter sd-button share-icon" href="https://www.somtribune.com/2022/08/23/kenya-hooligans-attempt-to-harm-iebc-officials/?share=twitter" target="_blank" title="Click to share on Twitter" ><span>Twitter</span></a></li><li class="share-reddit"><a rel="nofollow noopener noreferrer" data-shared="" class="share-reddit sd-button share-icon" href="https://www.somtribune.com/2022/08/23/kenya-hooligans-attempt-to-harm-iebc-officials/?share=reddit" target="_blank" title="Click to share on Reddit" ><span>Reddit</span></a></li><li class="share-jetpack-whatsapp"><a rel="nofollow noopener noreferrer" data-shared="" class="share-jetpack-whatsapp sd-button share-icon" href="https://www.somtribune.com/2022/08/23/kenya-hooligans-attempt-to-harm-iebc-officials/?share=jetpack-whatsapp" target="_blank" title="Click to share on WhatsApp" ><span>WhatsApp</span></a></li><li class="share-telegram"><a rel="nofollow noopener noreferrer" data-shared="" class="share-telegram sd-button share-icon" href="https://www.somtribune.com/2022/08/23/kenya-hooligans-attempt-to-harm-iebc-officials/?share=telegram" target="_blank" title="Click to share on Telegram" ><span>Telegram</span></a></li><li class="share-linkedin"><a rel="nofollow noopener noreferrer" data-shared="sharing-linkedin-64460" class="share-linkedin sd-button share-icon" href="https://www.somtribune.com/2022/08/23/kenya-hooligans-attempt-to-harm-iebc-officials/?share=linkedin" target="_blank" title="Click to share on LinkedIn" ><span>LinkedIn</span></a></li><li class="share-pinterest"><a rel="nofollow noopener noreferrer" data-shared="sharing-pinterest-64460" class="share-pinterest sd-button share-icon" href="https://www.somtribune.com/2022/08/23/kenya-hooligans-attempt-to-harm-iebc-officials/?share=pinterest" target="_blank" title="Click to share on Pinterest" ><span>Pinterest</span></a></li><li class="share-skype"><a rel="nofollow noopener noreferrer" data-shared="sharing-skype-64460" class="share-skype sd-button share-icon" href="https://www.somtribune.com/2022/08/23/kenya-hooligans-attempt-to-harm-iebc-officials/?share=skype" target="_blank" title="Click to share on Skype" ><span>Skype</span></a></li><li class="share-email"><a rel="nofollow noopener noreferrer" data-shared="" class="share-email sd-button share-icon" href="mailto:?subject=%5BShared%20Post%5D%20Kenya%3A%20Hooligans%20Attempt%20to%20Harm%20IEBC%20Officials&body=https%3A%2F%2Fwww.somtribune.com%2F2022%2F08%2F23%2Fkenya-hooligans-attempt-to-harm-iebc-officials%2F&share=email" target="_blank" title="Click to email a link to a friend" data-email-share-error-title="Do you have email set up?" data-email-share-error-text="If you&#039;re having problems sharing via email, you might not have email set up for your browser. You may need to create a new email yourself." data-email-share-nonce="38aec7dba4" data-email-share-track-url="https://www.somtribune.com/2022/08/23/kenya-hooligans-attempt-to-harm-iebc-officials/?share=email"><span>Email</span></a></li><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-64460" class="share-facebook sd-button share-icon" href="https://www.somtribune.com/2022/08/23/kenya-hooligans-attempt-to-harm-iebc-officials/?share=facebook" target="_blank" title="Click to share on Facebook" ><span>Facebook</span></a></li><li class="share-pocket"><a rel="nofollow noopener noreferrer" data-shared="" class="share-pocket sd-button share-icon" href="https://www.somtribune.com/2022/08/23/kenya-hooligans-attempt-to-harm-iebc-officials/?share=pocket" target="_blank" title="Click to share on Pocket" ><span>Pocket</span></a></li><li class="share-tumblr"><a rel="nofollow noopener noreferrer" data-shared="" class="share-tumblr sd-button share-icon" href="https://www.somtribune.com/2022/08/23/kenya-hooligans-attempt-to-harm-iebc-officials/?share=tumblr" target="_blank" title="Click to share on Tumblr" ><span>Tumblr</span></a></li><li class="share-print"><a rel="nofollow noopener noreferrer" data-shared="" class="share-print sd-button share-icon" href="https://www.somtribune.com/2022/08/23/kenya-hooligans-attempt-to-harm-iebc-officials/#print" target="_blank" title="Click to print" ><span>Print</span></a></li><li class="share-end"></li></ul></div></div></div><div class='sharedaddy sd-block sd-like jetpack-likes-widget-wrapper jetpack-likes-widget-unloaded' id='like-post-wrapper-80775917-64460-630578163a9cb' data-src='https://widgets.wp.com/likes/#blog_id=80775917&amp;post_id=64460&amp;origin=www.somtribune.com&amp;obj_id=80775917-64460-630578163a9cb' data-name='like-post-frame-80775917-64460-630578163a9cb' data-title='Like or Reblog'><h3 class="sd-title">Like this:</h3><div class='likes-widget-placeholder post-likes-widget-placeholder' style='height: 55px;'><span class='button'><span>Like</span></span> <span class="loading">Loading...</span></div><span class='sd-text-color'></span><a class='sd-link-color'></a></div>
<div id='jp-relatedposts' class='jp-relatedposts' >
	<h3 class="jp-relatedposts-headline"><em>Related</em></h3>
</div>        </div>


        <footer>
                        
            <div class="td-post-source-tags">
                                <ul class="td-tags td-post-small-box clearfix"><li><span>TAGS</span></li><li><a href="https://www.somtribune.com/tag/iebc/">IEBC</a></li><li><a href="https://www.somtribune.com/tag/kenya/">Kenya</a></li><li><a href="https://www.somtribune.com/tag/kenya-elections/">Kenya elections</a></li><li><a href="https://www.somtribune.com/tag/law-and-order/">Law and order</a></li></ul>            </div>

            <div class="td-post-sharing-bottom"><div class="td-post-sharing-classic"><iframe frameBorder="0" src="https://www.facebook.com/plugins/like.php?href=https://www.somtribune.com/2022/08/23/kenya-hooligans-attempt-to-harm-iebc-officials/&amp;layout=button_count&amp;show_faces=false&amp;width=105&amp;action=like&amp;colorscheme=light&amp;height=21" style="border:none; overflow:hidden; width:auto; height:21px; background-color:transparent;"></iframe></div><div id="td_social_sharing_article_bottom" class="td-post-sharing td-ps-bg td-ps-notext td-post-sharing-style1 "><div class="td-post-sharing-visible"><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.somtribune.com%2F2022%2F08%2F23%2Fkenya-hooligans-attempt-to-harm-iebc-officials%2F" title="Facebook" >
                                        <div class="td-social-but-icon"><i class="td-icon-facebook"></i></div>
                                        <div class="td-social-but-text">Facebook</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=Kenya%3A+Hooligans+Attempt+to+Harm+IEBC+Officials&url=https%3A%2F%2Fwww.somtribune.com%2F2022%2F08%2F23%2Fkenya-hooligans-attempt-to-harm-iebc-officials%2F&via=SomTribune" title="Twitter" >
                                        <div class="td-social-but-icon"><i class="td-icon-twitter"></i></div>
                                        <div class="td-social-but-text">Twitter</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-pinterest" href="https://pinterest.com/pin/create/button/?url=https://www.somtribune.com/2022/08/23/kenya-hooligans-attempt-to-harm-iebc-officials/&amp;media=https://www.somtribune.com/wp-content/uploads/2022/08/IEBC.jpg&description=Nairobi hotel when a group of about 50 people raided and attempted to attack Independent Electoral and Boundaries Commission (IEBC) personnel" title="Pinterest" >
                                        <div class="td-social-but-icon"><i class="td-icon-pinterest"></i></div>
                                        <div class="td-social-but-text">Pinterest</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-whatsapp" href="https://api.whatsapp.com/send?text=Kenya%3A+Hooligans+Attempt+to+Harm+IEBC+Officials %0A%0A https://www.somtribune.com/2022/08/23/kenya-hooligans-attempt-to-harm-iebc-officials/" title="WhatsApp" >
                                        <div class="td-social-but-icon"><i class="td-icon-whatsapp"></i></div>
                                        <div class="td-social-but-text">WhatsApp</div>
                                    </a></div><div class="td-social-sharing-hidden"><ul class="td-pulldown-filter-list"></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="td_social_sharing_article_bottom" title="More">
                                    <div class="td-social-but-icon"><i class="td-icon-plus td-social-expand-tabs-icon"></i></div>
                                </a></div></div></div>            <div class="td-block-row td-post-next-prev"><div class="td-block-span6 td-post-prev-post"><div class="td-post-next-prev-content"><span>Previous article</span><a href="https://www.somtribune.com/2022/08/23/somalian-president-facing-seemingly-insurmountable-challenges/">Somalian President Facing Seemingly Insurmountable Challenges</a></div></div><div class="td-next-prev-separator"></div><div class="td-block-span6 td-post-next-post"><div class="td-post-next-prev-content"><span>Next article</span><a href="https://www.somtribune.com/2022/08/23/indian-ocean-to-be-declared-free-of-piracy-next-year/">Indian Ocean to be Declared Free of Piracy Next Year</a></div></div></div>            <div class="author-box-wrap"><a href="https://www.somtribune.com/author/news-desk/" aria-label="author-photo"><img alt='' src='https://secure.gravatar.com/avatar/9ee783b426530732c3ff985ea907a5fe?s=96&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/9ee783b426530732c3ff985ea907a5fe?s=192&#038;d=mm&#038;r=g 2x' class='avatar avatar-96 photo' height='96' width='96' loading='lazy'/></a><div class="desc"><div class="td-author-name vcard author"><span class="fn"><a href="https://www.somtribune.com/author/news-desk/">News Desk</a></span></div><div class="td-author-description"></div><div class="td-author-social"></div><div class="clearfix"></div></div></div>	        <span class="td-page-meta" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="News Desk"><meta itemprop="url" content="https://www.somtribune.com/author/news-desk/"></span><meta itemprop="datePublished" content="2022-08-23T20:48:04+03:00"><meta itemprop="dateModified" content="2022-08-23T20:48:04+03:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="https://www.somtribune.com/2022/08/23/kenya-hooligans-attempt-to-harm-iebc-officials/"/><span class="td-page-meta" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span class="td-page-meta" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://somtribune.com/wp-content/uploads/2016/07/Logoo-300x90.png"></span><meta itemprop="name" content="SomTribune"></span><meta itemprop="headline " content="Kenya: Hooligans Attempt to Harm IEBC Officials"><span class="td-page-meta" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://www.somtribune.com/wp-content/uploads/2022/08/IEBC.jpg"><meta itemprop="width" content="624"><meta itemprop="height" content="351"></span>        </footer>

    <div class="td_block_wrap td_block_related_posts tdi_12 td_with_ajax_pagination td-pb-border-top td_block_template_1"  data-td-block-uid="tdi_12" ><script>var block_tdi_12 = new tdBlock();
block_tdi_12.id = "tdi_12";
block_tdi_12.atts = '{"limit":6,"ajax_pagination":"next_prev","live_filter":"cur_post_same_categories","td_ajax_filter_type":"td_custom_related","class":"tdi_12","td_column_number":3,"block_type":"td_block_related_posts","live_filter_cur_post_id":64460,"live_filter_cur_post_author":"15604","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_ajax_preloading":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","tdc_css_class":"tdi_12","tdc_css_class_style":"tdi_12_rand_style"}';
block_tdi_12.td_column_number = "3";
block_tdi_12.block_type = "td_block_related_posts";
block_tdi_12.post_count = "6";
block_tdi_12.found_posts = "2068";
block_tdi_12.header_color = "";
block_tdi_12.ajax_pagination_infinite_stop = "";
block_tdi_12.max_num_pages = "345";
tdBlocksArray.push(block_tdi_12);
</script><h4 class="td-related-title td-block-title"><a id="tdi_13" class="td-related-left td-cur-simple-item" data-td_filter_value="" data-td_block_id="tdi_12" href="#">RELATED ARTICLES</a><a id="tdi_14" class="td-related-right" data-td_filter_value="td_related_more_from_author" data-td_block_id="tdi_12" href="#">MORE FROM AUTHOR</a></h4><div id=tdi_12 class="td_block_inner">

	<div class="td-related-row">

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.somtribune.com/2022/08/23/indian-ocean-to-be-declared-free-of-piracy-next-year/" rel="bookmark" class="td-image-wrap " title="Indian Ocean to be Declared Free of Piracy Next Year" ><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="Indian Ocean to be Declared Free of Piracy Next Year" data-type="image_tag" data-img-url="https://www.somtribune.com/wp-content/uploads/2022/08/Piracyg-218x150.jpg"  width="218" height="150" /></a></div>                <a href="https://www.somtribune.com/category/worldinternational/crime-safety/" class="td-post-category">Conflict/Crime</a>            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.somtribune.com/2022/08/23/indian-ocean-to-be-declared-free-of-piracy-next-year/" rel="bookmark" title="Indian Ocean to be Declared Free of Piracy Next Year">Indian Ocean to be Declared Free of Piracy Next Year</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.somtribune.com/2022/08/23/somalian-president-facing-seemingly-insurmountable-challenges/" rel="bookmark" class="td-image-wrap " title="Somalian President Facing Seemingly Insurmountable Challenges" ><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="Somalian President Facing Seemingly Insurmountable Challenges" data-type="image_tag" data-img-url="https://www.somtribune.com/wp-content/uploads/2022/08/Hassan-Sh-Mohamud-p-1-218x150.png"  width="218" height="150" /></a></div>                <a href="https://www.somtribune.com/category/worldinternational/politics/" class="td-post-category">Politics/Diplomacy</a>            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.somtribune.com/2022/08/23/somalian-president-facing-seemingly-insurmountable-challenges/" rel="bookmark" title="Somalian President Facing Seemingly Insurmountable Challenges">Somalian President Facing Seemingly Insurmountable Challenges</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.somtribune.com/2022/08/23/somaliland-can-help-the-united-states-win-the-new-cold-war/" rel="bookmark" class="td-image-wrap " title="Somaliland Can Help The United States Win The New Cold War" ><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="Somaliland Can Help The United States Win The New Cold War" data-type="image_tag" data-img-url="https://www.somtribune.com/wp-content/uploads/2022/08/Photo-Resizer-2022_08_23_12_55_43-218x150.png"  width="218" height="150" /></a></div>                <a href="https://www.somtribune.com/category/worldinternational/politics/" class="td-post-category">Politics/Diplomacy</a>            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.somtribune.com/2022/08/23/somaliland-can-help-the-united-states-win-the-new-cold-war/" rel="bookmark" title="Somaliland Can Help The United States Win The New Cold War">Somaliland Can Help The United States Win The New Cold War</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 --></div><!--./row-fluid-->

	<div class="td-related-row">

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.somtribune.com/2022/08/22/kenya-odinga-challenges-poll-results-on-corruption-grounds/" rel="bookmark" class="td-image-wrap " title="Kenya: Odinga Challenges Poll Results on Corruption Grounds" ><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="Kenya: Odinga Challenges Poll Results on Corruption Grounds" data-type="image_tag" data-img-url="https://www.somtribune.com/wp-content/uploads/2022/08/Odinga-218x150.jpg"  width="218" height="150" /></a></div>                <a href="https://www.somtribune.com/category/worldinternational/africa/kenya/" class="td-post-category">Kenya</a>            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.somtribune.com/2022/08/22/kenya-odinga-challenges-poll-results-on-corruption-grounds/" rel="bookmark" title="Kenya: Odinga Challenges Poll Results on Corruption Grounds">Kenya: Odinga Challenges Poll Results on Corruption Grounds</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.somtribune.com/2022/08/18/exclusive-satellite-pics-chinas-new-mission-indian-ocean-targets-india/" rel="bookmark" class="td-image-wrap " title="Exclusive Satellite Pics: China&#8217;s New &#8216;Mission Indian Ocean&#8217; Targets India" ><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="Exclusive Satellite Pics: China&#8217;s New &#8216;Mission Indian Ocean&#8217; Targets India" data-type="image_tag" data-img-url="https://www.somtribune.com/wp-content/uploads/2022/08/Base-218x150.jpg"  width="218" height="150" /></a></div>                <a href="https://www.somtribune.com/category/worldinternational/africa/" class="td-post-category">Africa</a>            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.somtribune.com/2022/08/18/exclusive-satellite-pics-chinas-new-mission-indian-ocean-targets-india/" rel="bookmark" title="Exclusive Satellite Pics: China&#8217;s New &#8216;Mission Indian Ocean&#8217; Targets India">Exclusive Satellite Pics: China&#8217;s New &#8216;Mission Indian Ocean&#8217; Targets India</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.somtribune.com/2022/08/18/somaliland-advisory-group-urge-political-stakeholders-to-engage-in-substantive-dialogue/" rel="bookmark" class="td-image-wrap " title="Somaliland Advisory Group Urge Political Stakeholders to Engage in Substantive Dialogue" ><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="Somaliland Advisory Group Urge Political Stakeholders to Engage in Substantive Dialogue" data-type="image_tag" data-img-url="https://www.somtribune.com/wp-content/uploads/2022/08/Somaliland-First-1-218x150.jpg"  width="218" height="150" /></a></div>                <a href="https://www.somtribune.com/category/worldinternational/politics/" class="td-post-category">Politics/Diplomacy</a>            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.somtribune.com/2022/08/18/somaliland-advisory-group-urge-political-stakeholders-to-engage-in-substantive-dialogue/" rel="bookmark" title="Somaliland Advisory Group Urge Political Stakeholders to Engage in Substantive Dialogue">Somaliland Advisory Group Urge Political Stakeholders to Engage in Substantive Dialogue</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 --></div><!--./row-fluid--></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" aria-label="prev-page" id="prev-page-tdi_12" data-td_block_id="tdi_12"><i class="td-next-prev-icon td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" aria-label="next-page" id="next-page-tdi_12" data-td_block_id="tdi_12"><i class="td-next-prev-icon td-icon-font td-icon-menu-right"></i></a></div></div> <!-- ./block -->
    <div class="comments" id="comments">
        	<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">LEAVE A REPLY <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2022/08/23/kenya-hooligans-attempt-to-harm-iebc-officials/?utm_source=rss&amp;utm_medium=rss&amp;utm_campaign=kenya-hooligans-attempt-to-harm-iebc-officials#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://www.somtribune.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><div class="clearfix"></div>
				<div class="comment-form-input-wrap td-form-comment">
					<textarea placeholder="Comment:" id="comment" name="comment" cols="45" rows="8" aria-required="true"></textarea>
					<div class="td-warning-comment">Please enter your comment!</div>
				</div>
		        <div class="comment-form-input-wrap td-form-author">
			            <input class="" id="author" name="author" placeholder="Name:*" type="text" value="" size="30"  aria-required='true' />
			            <div class="td-warning-author">Please enter your name here</div>
			         </div>
<div class="comment-form-input-wrap td-form-email">
			            <input class="" id="email" name="email" placeholder="Email:*" type="text" value="" size="30"  aria-required='true' />
			            <div class="td-warning-email-error">You have entered an incorrect email address!</div>
			            <div class="td-warning-email">Please enter your email address here</div>
			         </div>
<div class="comment-form-input-wrap td-form-url">
			            <input class="" id="url" name="url" placeholder="Website:" type="text" value="" size="30" />
                     </div>
<p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /><label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p>
<p class="comment-subscription-form"><input type="checkbox" name="subscribe_comments" id="subscribe_comments" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label class="subscribe-label" id="subscribe-label" for="subscribe_comments">Notify me of follow-up comments by email.</label></p><p class="comment-subscription-form"><input type="checkbox" name="subscribe_blog" id="subscribe_blog" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label class="subscribe-label" id="subscribe-blog-label" for="subscribe_blog">Notify me of new posts by email.</label></p><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='64460' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="85770ff14e" /></p><p style="display: none !important;"><label>&#916;<textarea name="ak_hp_textarea" cols="45" rows="8" maxlength="100"></textarea></label><input type="hidden" id="ak_js_1" name="ak_js" value="63"/><script>document.getElementById( "ak_js_1" ).setAttribute( "value", ( new Date() ).getTime() );</script></p></form>	</div><!-- #respond -->
	    </div> <!-- /.content -->
                                    </div>
                            </div>
                            <div class="td-pb-span4 td-main-sidebar" role="complementary">
                                <div class="td-ss-main-sidebar">
                                    <aside id="custom_html-2" class="widget_text td_block_template_1 widget custom_html-2 widget_custom_html"><div class="textwidget custom-html-widget"><script id="apo-widget-script" src="https://www.africa-newsroom.com/addons/shared_addons/modules/africarc/js/widget.min.js?token=Tzo4OiJzdGRDbGFzcyI6Mzp7czo5OiJsYW5ndWFnZXMiO3M6MTk6ImE6MTp7aTowO3M6MjoiZW4iO30iO3M6NDoidHlwZSI7czoxOiJ3IjtzOjExOiJub19vZl9pdGVtcyI7aTo1O30=" type="text/javascript"></script>
<div id="apo-widget-container"></div></div></aside>                                </div>
                            </div>
                                    </div> <!-- /.td-pb-row -->
        </article> <!-- /.post -->
    </div> <!-- /.td-container -->
</div> <!-- /.td-main-content-wrap -->

<!-- Instagram -->

	
	
            <div class="tdc-footer-wrap ">

                <!-- Footer -->
				
                <!-- Sub Footer -->
				    <div class="td-sub-footer-container td-container-wrap ">
        <div class="td-container">
            <div class="td-pb-row">
                <div class="td-pb-span td-sub-footer-menu">
                    <div class="menu-main-menu-container"><ul id="menu-main-menu-2" class="td-subfooter-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-first td-menu-item td-normal-menu menu-item-26091"><a href="https://www.somtribune.com/">Home</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-64391"><a href="https://www.somtribune.com/category/featured/">Featured</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children td-menu-item td-mega-menu menu-item-61578"><a href="https://www.somtribune.com/category/somaliland/">News</a>
<ul class="sub-menu">
	<li class="menu-item-0"><a><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu tdi_15 td-no-subcats td_with_ajax_pagination td-pb-border-top td_block_template_1 td_ajax_preloading_preload"  data-td-block-uid="tdi_15" ><script>var block_tdi_15 = new tdBlock();
block_tdi_15.id = "tdi_15";
block_tdi_15.atts = '{"limit":"5","td_column_number":3,"ajax_pagination":"next_prev","category_id":"2","show_child_cat":30,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"preload","block_type":"td_block_mega_menu","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"tdi_15","tdc_css_class":"tdi_15","tdc_css_class_style":"tdi_15_rand_style"}';
block_tdi_15.td_column_number = "3";
block_tdi_15.block_type = "td_block_mega_menu";
block_tdi_15.post_count = "5";
block_tdi_15.found_posts = "3196";
block_tdi_15.header_color = "";
block_tdi_15.ajax_pagination_infinite_stop = "";
block_tdi_15.max_num_pages = "640";
tdBlocksArray.push(block_tdi_15);
</script><div id=tdi_15 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.somtribune.com/2022/08/23/somaliland-can-help-the-united-states-win-the-new-cold-war/" rel="bookmark" class="td-image-wrap " title="Somaliland Can Help The United States Win The New Cold War" ><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="Somaliland Can Help The United States Win The New Cold War" data-type="image_tag" data-img-url="https://www.somtribune.com/wp-content/uploads/2022/08/Photo-Resizer-2022_08_23_12_55_43-218x150.png"  width="218" height="150" /></a></div>                <a href="https://www.somtribune.com/category/worldinternational/politics/" class="td-post-category">Politics/Diplomacy</a>            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.somtribune.com/2022/08/23/somaliland-can-help-the-united-states-win-the-new-cold-war/" rel="bookmark" title="Somaliland Can Help The United States Win The New Cold War">Somaliland Can Help The United States Win The New Cold War</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.somtribune.com/2022/08/19/somaliland-mourns-death-of-greatest-of-contemporary-somali-poets-hadraawi/" rel="bookmark" class="td-image-wrap " title="Somaliland Mourns Death of Greatest of Contemporary Somali Poets &#8211; Hadraawi" ><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="Somaliland Mourns Death of Greatest of Contemporary Somali Poets &#8211; Hadraawi" data-type="image_tag" data-img-url="https://www.somtribune.com/wp-content/uploads/2022/08/Hadrawi-Umbrella1-218x150.png"  width="218" height="150" /></a></div>                <a href="https://www.somtribune.com/category/culture/artliterature/" class="td-post-category">Art/Literature</a>            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.somtribune.com/2022/08/19/somaliland-mourns-death-of-greatest-of-contemporary-somali-poets-hadraawi/" rel="bookmark" title="Somaliland Mourns Death of Greatest of Contemporary Somali Poets &#8211; Hadraawi">Somaliland Mourns Death of Greatest of Contemporary Somali Poets &#8211; Hadraawi</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.somtribune.com/2022/08/19/somaliland-modern-day-shakespeare-mohamed-i-warsame-hadrawi-the-man-and-the-poet-a-review/" rel="bookmark" class="td-image-wrap " title="Somaliland: Modern Day Shakespeare, Mohamed I Warsame Hadrawi: The Man and the Poet &#8211; A Review" ><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="Somaliland: Modern Day Shakespeare, Mohamed I Warsame Hadrawi: The Man and the Poet &#8211; A Review" data-type="image_tag" data-img-url="https://www.somtribune.com/wp-content/uploads/2022/08/Hadrawi1-218x150.jpg"  width="218" height="150" /></a></div>                <a href="https://www.somtribune.com/category/culture/artliterature/" class="td-post-category">Art/Literature</a>            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.somtribune.com/2022/08/19/somaliland-modern-day-shakespeare-mohamed-i-warsame-hadrawi-the-man-and-the-poet-a-review/" rel="bookmark" title="Somaliland: Modern Day Shakespeare, Mohamed I Warsame Hadrawi: The Man and the Poet &#8211; A Review">Somaliland: Modern Day Shakespeare, Mohamed I Warsame Hadrawi: The Man and&#8230;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.somtribune.com/2022/08/19/suhura-ismail-the-entrepreneur-khat-crowned-queen/" rel="bookmark" class="td-image-wrap " title="Suhura Ismail &#8211; the Entrepreneur Khat Crowned Queen" ><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="Suhura Ismail &#8211; the Entrepreneur Khat Crowned Queen" data-type="image_tag" data-img-url="https://www.somtribune.com/wp-content/uploads/2022/07/Suhura-Ismail-218x150.jpeg"  width="218" height="150" /></a></div>                <a href="https://www.somtribune.com/category/worldinternational/africa/" class="td-post-category">Africa</a>            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.somtribune.com/2022/08/19/suhura-ismail-the-entrepreneur-khat-crowned-queen/" rel="bookmark" title="Suhura Ismail &#8211; the Entrepreneur Khat Crowned Queen">Suhura Ismail &#8211; the Entrepreneur Khat Crowned Queen</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.somtribune.com/2022/08/18/somaliland-advisory-group-urge-political-stakeholders-to-engage-in-substantive-dialogue/" rel="bookmark" class="td-image-wrap " title="Somaliland Advisory Group Urge Political Stakeholders to Engage in Substantive Dialogue" ><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="Somaliland Advisory Group Urge Political Stakeholders to Engage in Substantive Dialogue" data-type="image_tag" data-img-url="https://www.somtribune.com/wp-content/uploads/2022/08/Somaliland-First-1-218x150.jpg"  width="218" height="150" /></a></div>                <a href="https://www.somtribune.com/category/worldinternational/politics/" class="td-post-category">Politics/Diplomacy</a>            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.somtribune.com/2022/08/18/somaliland-advisory-group-urge-political-stakeholders-to-engage-in-substantive-dialogue/" rel="bookmark" title="Somaliland Advisory Group Urge Political Stakeholders to Engage in Substantive Dialogue">Somaliland Advisory Group Urge Political Stakeholders to Engage in Substantive Dialogue</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" aria-label="prev-page" id="prev-page-tdi_15" data-td_block_id="tdi_15"><i class="td-next-prev-icon td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" aria-label="next-page" id="next-page-tdi_15" data-td_block_id="tdi_15"><i class="td-next-prev-icon td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-24"><a href="https://www.somtribune.com/category/somaliland/">Somaliland</a>
	<ul class="sub-menu">
		<li class="menu-item-0"><a><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu tdi_16 td-no-subcats td_with_ajax_pagination td-pb-border-top td_block_template_1 td_ajax_preloading_preload"  data-td-block-uid="tdi_16" ><script>var block_tdi_16 = new tdBlock();
block_tdi_16.id = "tdi_16";
block_tdi_16.atts = '{"limit":"5","td_column_number":3,"ajax_pagination":"next_prev","category_id":"2","show_child_cat":30,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"preload","block_type":"td_block_mega_menu","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"tdi_16","tdc_css_class":"tdi_16","tdc_css_class_style":"tdi_16_rand_style"}';
block_tdi_16.td_column_number = "3";
block_tdi_16.block_type = "td_block_mega_menu";
block_tdi_16.post_count = "5";
block_tdi_16.found_posts = "3196";
block_tdi_16.header_color = "";
block_tdi_16.ajax_pagination_infinite_stop = "";
block_tdi_16.max_num_pages = "640";
tdBlocksArray.push(block_tdi_16);
</script><div id=tdi_16 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.somtribune.com/2022/08/23/somaliland-can-help-the-united-states-win-the-new-cold-war/" rel="bookmark" class="td-image-wrap " title="Somaliland Can Help The United States Win The New Cold War" ><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="Somaliland Can Help The United States Win The New Cold War" data-type="image_tag" data-img-url="https://www.somtribune.com/wp-content/uploads/2022/08/Photo-Resizer-2022_08_23_12_55_43-218x150.png"  width="218" height="150" /></a></div>                <a href="https://www.somtribune.com/category/worldinternational/politics/" class="td-post-category">Politics/Diplomacy</a>            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.somtribune.com/2022/08/23/somaliland-can-help-the-united-states-win-the-new-cold-war/" rel="bookmark" title="Somaliland Can Help The United States Win The New Cold War">Somaliland Can Help The United States Win The New Cold War</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.somtribune.com/2022/08/19/somaliland-mourns-death-of-greatest-of-contemporary-somali-poets-hadraawi/" rel="bookmark" class="td-image-wrap " title="Somaliland Mourns Death of Greatest of Contemporary Somali Poets &#8211; Hadraawi" ><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="Somaliland Mourns Death of Greatest of Contemporary Somali Poets &#8211; Hadraawi" data-type="image_tag" data-img-url="https://www.somtribune.com/wp-content/uploads/2022/08/Hadrawi-Umbrella1-218x150.png"  width="218" height="150" /></a></div>                <a href="https://www.somtribune.com/category/culture/artliterature/" class="td-post-category">Art/Literature</a>            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.somtribune.com/2022/08/19/somaliland-mourns-death-of-greatest-of-contemporary-somali-poets-hadraawi/" rel="bookmark" title="Somaliland Mourns Death of Greatest of Contemporary Somali Poets &#8211; Hadraawi">Somaliland Mourns Death of Greatest of Contemporary Somali Poets &#8211; Hadraawi</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.somtribune.com/2022/08/19/somaliland-modern-day-shakespeare-mohamed-i-warsame-hadrawi-the-man-and-the-poet-a-review/" rel="bookmark" class="td-image-wrap " title="Somaliland: Modern Day Shakespeare, Mohamed I Warsame Hadrawi: The Man and the Poet &#8211; A Review" ><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="Somaliland: Modern Day Shakespeare, Mohamed I Warsame Hadrawi: The Man and the Poet &#8211; A Review" data-type="image_tag" data-img-url="https://www.somtribune.com/wp-content/uploads/2022/08/Hadrawi1-218x150.jpg"  width="218" height="150" /></a></div>                <a href="https://www.somtribune.com/category/culture/artliterature/" class="td-post-category">Art/Literature</a>            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.somtribune.com/2022/08/19/somaliland-modern-day-shakespeare-mohamed-i-warsame-hadrawi-the-man-and-the-poet-a-review/" rel="bookmark" title="Somaliland: Modern Day Shakespeare, Mohamed I Warsame Hadrawi: The Man and the Poet &#8211; A Review">Somaliland: Modern Day Shakespeare, Mohamed I Warsame Hadrawi: The Man and&#8230;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.somtribune.com/2022/08/19/suhura-ismail-the-entrepreneur-khat-crowned-queen/" rel="bookmark" class="td-image-wrap " title="Suhura Ismail &#8211; the Entrepreneur Khat Crowned Queen" ><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="Suhura Ismail &#8211; the Entrepreneur Khat Crowned Queen" data-type="image_tag" data-img-url="https://www.somtribune.com/wp-content/uploads/2022/07/Suhura-Ismail-218x150.jpeg"  width="218" height="150" /></a></div>                <a href="https://www.somtribune.com/category/worldinternational/africa/" class="td-post-category">Africa</a>            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.somtribune.com/2022/08/19/suhura-ismail-the-entrepreneur-khat-crowned-queen/" rel="bookmark" title="Suhura Ismail &#8211; the Entrepreneur Khat Crowned Queen">Suhura Ismail &#8211; the Entrepreneur Khat Crowned Queen</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.somtribune.com/2022/08/18/somaliland-advisory-group-urge-political-stakeholders-to-engage-in-substantive-dialogue/" rel="bookmark" class="td-image-wrap " title="Somaliland Advisory Group Urge Political Stakeholders to Engage in Substantive Dialogue" ><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="Somaliland Advisory Group Urge Political Stakeholders to Engage in Substantive Dialogue" data-type="image_tag" data-img-url="https://www.somtribune.com/wp-content/uploads/2022/08/Somaliland-First-1-218x150.jpg"  width="218" height="150" /></a></div>                <a href="https://www.somtribune.com/category/worldinternational/politics/" class="td-post-category">Politics/Diplomacy</a>            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.somtribune.com/2022/08/18/somaliland-advisory-group-urge-political-stakeholders-to-engage-in-substantive-dialogue/" rel="bookmark" title="Somaliland Advisory Group Urge Political Stakeholders to Engage in Substantive Dialogue">Somaliland Advisory Group Urge Political Stakeholders to Engage in Substantive Dialogue</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" aria-label="prev-page" id="prev-page-tdi_16" data-td_block_id="tdi_16"><i class="td-next-prev-icon td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" aria-label="next-page" id="next-page-tdi_16" data-td_block_id="tdi_16"><i class="td-next-prev-icon td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></a></li>
	</ul>
</li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-23"><a href="https://www.somtribune.com/category/somalia/">Somalia</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor td-menu-item td-normal-menu menu-item-26"><a href="https://www.somtribune.com/category/worldinternational/">World News/International</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor td-menu-item td-normal-menu menu-item-18"><a href="https://www.somtribune.com/category/worldinternational/africa/">Africa</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-25"><a href="https://www.somtribune.com/category/sports/">Sports</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-19"><a href="https://www.somtribune.com/category/economy/">Economy/Business</a>
<ul class="sub-menu">
	<li class="menu-item-0"><a><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu tdi_17 td_with_ajax_pagination td-pb-border-top td_block_template_1 td_ajax_preloading_preload"  data-td-block-uid="tdi_17" ><script>var block_tdi_17 = new tdBlock();
block_tdi_17.id = "tdi_17";
block_tdi_17.atts = '{"limit":4,"td_column_number":3,"ajax_pagination":"next_prev","category_id":"7","show_child_cat":30,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"preload","block_type":"td_block_mega_menu","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"tdi_17","tdc_css_class":"tdi_17","tdc_css_class_style":"tdi_17_rand_style"}';
block_tdi_17.td_column_number = "3";
block_tdi_17.block_type = "td_block_mega_menu";
block_tdi_17.post_count = "4";
block_tdi_17.found_posts = "1281";
block_tdi_17.header_color = "";
block_tdi_17.ajax_pagination_infinite_stop = "";
block_tdi_17.max_num_pages = "321";
tdBlocksArray.push(block_tdi_17);
</script>            <script>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</script>
            <div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-tdi_17" id="tdi_18" data-td_block_id="tdi_17" data-td_filter_value="" href="https://www.somtribune.com/category/economy/">All</a><a class="mega-menu-sub-cat-tdi_17"  id="tdi_19" data-td_block_id="tdi_17" data-td_filter_value="905" href="https://www.somtribune.com/category/economy/finance/">Finance</a><a class="mega-menu-sub-cat-tdi_17"  id="tdi_20" data-td_block_id="tdi_17" data-td_filter_value="940" href="https://www.somtribune.com/category/economy/markets/">Markets</a></div></div><div id=tdi_17 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.somtribune.com/2022/08/19/suhura-ismail-the-entrepreneur-khat-crowned-queen/" rel="bookmark" class="td-image-wrap " title="Suhura Ismail &#8211; the Entrepreneur Khat Crowned Queen" ><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="Suhura Ismail &#8211; the Entrepreneur Khat Crowned Queen" data-type="image_tag" data-img-url="https://www.somtribune.com/wp-content/uploads/2022/07/Suhura-Ismail-218x150.jpeg"  width="218" height="150" /></a></div>                <a href="https://www.somtribune.com/category/worldinternational/africa/" class="td-post-category">Africa</a>            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.somtribune.com/2022/08/19/suhura-ismail-the-entrepreneur-khat-crowned-queen/" rel="bookmark" title="Suhura Ismail &#8211; the Entrepreneur Khat Crowned Queen">Suhura Ismail &#8211; the Entrepreneur Khat Crowned Queen</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.somtribune.com/2022/08/16/first-post-blockade-food-aid-ship-leaves-ukraine-for-africa/" rel="bookmark" class="td-image-wrap " title="First Post-Blockade Food Aid Ship Leaves Ukraine for Africa" ><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="First Post-Blockade Food Aid Ship Leaves Ukraine for Africa" data-type="image_tag" data-img-url="https://www.somtribune.com/wp-content/uploads/2022/08/Wheat-218x150.jpg"  width="218" height="150" /></a></div>                <a href="https://www.somtribune.com/category/worldinternational/africa/" class="td-post-category">Africa</a>            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.somtribune.com/2022/08/16/first-post-blockade-food-aid-ship-leaves-ukraine-for-africa/" rel="bookmark" title="First Post-Blockade Food Aid Ship Leaves Ukraine for Africa">First Post-Blockade Food Aid Ship Leaves Ukraine for Africa</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.somtribune.com/2022/08/13/ethiopia-completes-third-filling-of-blue-nile-mega-dam/" rel="bookmark" class="td-image-wrap " title="Ethiopia Completes Third Filling of Blue Nile Mega Dam" ><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC"alt="" data-type="image_tag" data-img-url="https://www.somtribune.com/wp-content/plugins/td-composer/legacy/Newspaper/assets/images/no-thumb/td_218x150.png"  width="218" height="150" /><span class="td-video-play-ico"><i class="td-icon-video-thumb-play"></i></span></a></div>                <a href="https://www.somtribune.com/category/economy/" class="td-post-category">Economy/Business</a>            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.somtribune.com/2022/08/13/ethiopia-completes-third-filling-of-blue-nile-mega-dam/" rel="bookmark" title="Ethiopia Completes Third Filling of Blue Nile Mega Dam">Ethiopia Completes Third Filling of Blue Nile Mega Dam</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.somtribune.com/2022/08/09/uganda-somalia-stage-business-summit-in-kampala/" rel="bookmark" class="td-image-wrap " title="Uganda, Somalia Stage Business Summit in Kampala" ><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="Uganda, Somalia Stage Business Summit in Kampala" data-type="image_tag" data-img-url="https://www.somtribune.com/wp-content/uploads/2022/08/Info--218x150.jpeg"  width="218" height="150" /></a></div>                <a href="https://www.somtribune.com/category/worldinternational/africa/" class="td-post-category">Africa</a>            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.somtribune.com/2022/08/09/uganda-somalia-stage-business-summit-in-kampala/" rel="bookmark" title="Uganda, Somalia Stage Business Summit in Kampala">Uganda, Somalia Stage Business Summit in Kampala</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" aria-label="prev-page" id="prev-page-tdi_17" data-td_block_id="tdi_17"><i class="td-next-prev-icon td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" aria-label="next-page" id="next-page-tdi_17" data-td_block_id="tdi_17"><i class="td-next-prev-icon td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-21"><a href="https://www.somtribune.com/category/editorial/">Editorial</a>
<ul class="sub-menu">
	<li class="menu-item-0"><a><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu tdi_21 td-no-subcats td_with_ajax_pagination td-pb-border-top td_block_template_1 td_ajax_preloading_preload"  data-td-block-uid="tdi_21" ><script>var block_tdi_21 = new tdBlock();
block_tdi_21.id = "tdi_21";
block_tdi_21.atts = '{"limit":"5","td_column_number":3,"ajax_pagination":"next_prev","category_id":"10","show_child_cat":30,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"preload","block_type":"td_block_mega_menu","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"tdi_21","tdc_css_class":"tdi_21","tdc_css_class_style":"tdi_21_rand_style"}';
block_tdi_21.td_column_number = "3";
block_tdi_21.block_type = "td_block_mega_menu";
block_tdi_21.post_count = "5";
block_tdi_21.found_posts = "29";
block_tdi_21.header_color = "";
block_tdi_21.ajax_pagination_infinite_stop = "";
block_tdi_21.max_num_pages = "6";
tdBlocksArray.push(block_tdi_21);
</script><div id=tdi_21 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.somtribune.com/2021/02/25/partners-call-somalia-government-fms-to-agree-on-crucial-issues-including-non-member-somaliland-mps/" rel="bookmark" class="td-image-wrap " title="Partners Call Somalia Government, FMS to Agree on Crucial Issues Including Non-member Somaliland MPs" ><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="Partners Call Somalia Government, FMS to Agree on Crucial Issues Including Non-member Somaliland MPs" data-type="image_tag" data-img-url="https://www.somtribune.com/wp-content/uploads/2021/02/Somalia-Partners-VS-Somaliland-218x150.jpg"  width="218" height="150" /></a></div>                <a href="https://www.somtribune.com/category/editorial/" class="td-post-category">Editorial</a>            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.somtribune.com/2021/02/25/partners-call-somalia-government-fms-to-agree-on-crucial-issues-including-non-member-somaliland-mps/" rel="bookmark" title="Partners Call Somalia Government, FMS to Agree on Crucial Issues Including Non-member Somaliland MPs">Partners Call Somalia Government, FMS to Agree on Crucial Issues Including&#8230;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.somtribune.com/2020/05/18/somaliland-is-covid-19-wholly-responsible-for-a-dead-29th-18-may-anniversary-festive-mood/" rel="bookmark" class="td-image-wrap " title="Somaliland: Is COVID-19 Wholly Responsible for a Dead 29th 18 May Anniversary Festive Mood?" ><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="Somaliland: Is COVID-19 Wholly Responsible for a Dead 29th 18 May Anniversary Festive Mood?" data-type="image_tag" data-img-url="https://www.somtribune.com/wp-content/uploads/2020/05/Somaliland-Map-218x150.jpeg"  width="218" height="150" /></a></div>                <a href="https://www.somtribune.com/category/editorial/" class="td-post-category">Editorial</a>            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.somtribune.com/2020/05/18/somaliland-is-covid-19-wholly-responsible-for-a-dead-29th-18-may-anniversary-festive-mood/" rel="bookmark" title="Somaliland: Is COVID-19 Wholly Responsible for a Dead 29th 18 May Anniversary Festive Mood?">Somaliland: Is COVID-19 Wholly Responsible for a Dead 29th 18 May&#8230;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.somtribune.com/2020/05/07/somalia-openly-portrays-somaliland-as-a-federal-entity-for-1st-time/" rel="bookmark" class="td-image-wrap " title="Somalia Openly Portrays Somaliland as a Federal Entity for 1st Time" ><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="Somalia Openly Portrays Somaliland as a Federal Entity for 1st Time" data-type="image_tag" data-img-url="https://www.somtribune.com/wp-content/uploads/2020/05/DF-218x150.jpg"  width="218" height="150" /></a></div>                <a href="https://www.somtribune.com/category/editorial/" class="td-post-category">Editorial</a>            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.somtribune.com/2020/05/07/somalia-openly-portrays-somaliland-as-a-federal-entity-for-1st-time/" rel="bookmark" title="Somalia Openly Portrays Somaliland as a Federal Entity for 1st Time">Somalia Openly Portrays Somaliland as a Federal Entity for 1st Time</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.somtribune.com/2020/02/21/somaliland-is-renewed-ethio-somalia-relations-bringing-the-zeila-equation-back-into-focus/" rel="bookmark" class="td-image-wrap " title="Somaliland: Is Renewed Ethio-Somalia Relations Bringing The Zeila Equation Back Into Focus?" ><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="Somaliland: Is Renewed Ethio-Somalia Relations Bringing The Zeila Equation Back Into Focus?" data-type="image_tag" data-img-url="https://www.somtribune.com/wp-content/uploads/2020/02/Screen-Shot-2020-02-21-at-10.47.18-PM-218x150.png"  width="218" height="150" /></a></div>                <a href="https://www.somtribune.com/category/editorial/" class="td-post-category">Editorial</a>            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.somtribune.com/2020/02/21/somaliland-is-renewed-ethio-somalia-relations-bringing-the-zeila-equation-back-into-focus/" rel="bookmark" title="Somaliland: Is Renewed Ethio-Somalia Relations Bringing The Zeila Equation Back Into Focus?">Somaliland: Is Renewed Ethio-Somalia Relations Bringing The Zeila Equation Back Into&#8230;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.somtribune.com/2020/02/13/farmajo-compounds-somalia-genocide-against-somaliland-with-jesting-apology/" rel="bookmark" class="td-image-wrap " title="Farmajo Compounds Somalia Genocide Against Somaliland With Jesting &#8216;Apology&#8217;" ><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="Farmajo Compounds Somalia Genocide Against Somaliland With Jesting &#8216;Apology&#8217;" data-type="image_tag" data-img-url="https://www.somtribune.com/wp-content/uploads/2020/02/maxresdefault-5-218x150.jpg"  width="218" height="150" /><span class="td-video-play-ico"><i class="td-icon-video-thumb-play"></i></span></a></div>                <a href="https://www.somtribune.com/category/editorial/" class="td-post-category">Editorial</a>            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.somtribune.com/2020/02/13/farmajo-compounds-somalia-genocide-against-somaliland-with-jesting-apology/" rel="bookmark" title="Farmajo Compounds Somalia Genocide Against Somaliland With Jesting &#8216;Apology&#8217;">Farmajo Compounds Somalia Genocide Against Somaliland With Jesting &#8216;Apology&#8217;</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" aria-label="prev-page" id="prev-page-tdi_21" data-td_block_id="tdi_21"><i class="td-next-prev-icon td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" aria-label="next-page" id="next-page-tdi_21" data-td_block_id="tdi_21"><i class="td-next-prev-icon td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-22"><a href="https://www.somtribune.com/category/opinionanalysis/">Opinion/Analysis</a>
<ul class="sub-menu">
	<li class="menu-item-0"><a><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu tdi_22 td-no-subcats td_with_ajax_pagination td-pb-border-top td_block_template_1 td_ajax_preloading_preload"  data-td-block-uid="tdi_22" ><script>var block_tdi_22 = new tdBlock();
block_tdi_22.id = "tdi_22";
block_tdi_22.atts = '{"limit":"5","td_column_number":3,"ajax_pagination":"next_prev","category_id":"4","show_child_cat":30,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"preload","block_type":"td_block_mega_menu","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"tdi_22","tdc_css_class":"tdi_22","tdc_css_class_style":"tdi_22_rand_style"}';
block_tdi_22.td_column_number = "3";
block_tdi_22.block_type = "td_block_mega_menu";
block_tdi_22.post_count = "5";
block_tdi_22.found_posts = "537";
block_tdi_22.header_color = "";
block_tdi_22.ajax_pagination_infinite_stop = "";
block_tdi_22.max_num_pages = "108";
tdBlocksArray.push(block_tdi_22);
</script><div id=tdi_22 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.somtribune.com/2022/08/18/remembering-hadrawi-my-teacher-mentor-and-friend/" rel="bookmark" class="td-image-wrap " title="Remembering Hadrawi: My Teacher, Mentor and Friend" ><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="Remembering Hadrawi: My Teacher, Mentor and Friend" data-type="image_tag" data-img-url="https://www.somtribune.com/wp-content/uploads/2022/08/Abu-Hadra-210x150.jpeg"  width="210" height="150" /></a></div>                <a href="https://www.somtribune.com/category/culture/artliterature/" class="td-post-category">Art/Literature</a>            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.somtribune.com/2022/08/18/remembering-hadrawi-my-teacher-mentor-and-friend/" rel="bookmark" title="Remembering Hadrawi: My Teacher, Mentor and Friend">Remembering Hadrawi: My Teacher, Mentor and Friend</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.somtribune.com/2022/08/16/more-chinese-military-bases-in-africa-a-question-of-when-not-if/" rel="bookmark" class="td-image-wrap " title="More Chinese Military Bases in Africa: A Question of When, Not If" ><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="More Chinese Military Bases in Africa: A Question of When, Not If" data-type="image_tag" data-img-url="https://www.somtribune.com/wp-content/uploads/2022/08/Chinese-bases-218x150.jpg"  width="218" height="150" /></a></div>                <a href="https://www.somtribune.com/category/worldinternational/africa/" class="td-post-category">Africa</a>            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.somtribune.com/2022/08/16/more-chinese-military-bases-in-africa-a-question-of-when-not-if/" rel="bookmark" title="More Chinese Military Bases in Africa: A Question of When, Not If">More Chinese Military Bases in Africa: A Question of When, Not&#8230;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.somtribune.com/2022/06/30/i-saw-prince-charles-inspire-hope-at-the-commonwealth-summit-nimco-ali/" rel="bookmark" class="td-image-wrap " title="I saw Prince Charles Inspire Hope at the Commonwealth Summit &#8211; Nimco Ali" ><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="I saw Prince Charles Inspire Hope at the Commonwealth Summit &#8211; Nimco Ali" data-type="image_tag" data-img-url="https://www.somtribune.com/wp-content/uploads/2022/06/Nimco-Ali-218x150.jpg"  width="218" height="150" /></a></div>                <a href="https://www.somtribune.com/category/opinionanalysis/" class="td-post-category">Opinion/Analysis</a>            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.somtribune.com/2022/06/30/i-saw-prince-charles-inspire-hope-at-the-commonwealth-summit-nimco-ali/" rel="bookmark" title="I saw Prince Charles Inspire Hope at the Commonwealth Summit &#8211; Nimco Ali">I saw Prince Charles Inspire Hope at the Commonwealth Summit &#8211;&#8230;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.somtribune.com/2022/06/25/it-may-be-too-late-to-save-america/" rel="bookmark" class="td-image-wrap " title="It May Be Too Late to Save America" ><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="It May Be Too Late to Save America" data-type="image_tag" data-img-url="https://www.somtribune.com/wp-content/uploads/2022/06/demonstrators-protest-front-scotus-218x150.webp"  width="218" height="150" /></a></div>                <a href="https://www.somtribune.com/category/opinionanalysis/" class="td-post-category">Opinion/Analysis</a>            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.somtribune.com/2022/06/25/it-may-be-too-late-to-save-america/" rel="bookmark" title="It May Be Too Late to Save America">It May Be Too Late to Save America</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.somtribune.com/2022/06/04/somaliland-berbera-port-shows-true-value-of-doing-over-dithering/" rel="bookmark" class="td-image-wrap " title="Somaliland: Berbera Port Shows True Value of Doing Over Dithering" ><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="Somaliland: Berbera Port Shows True Value of Doing Over Dithering" data-type="image_tag" data-img-url="https://www.somtribune.com/wp-content/uploads/2022/06/John-Steenhuisen-218x150.jpg"  width="218" height="150" /></a></div>                <a href="https://www.somtribune.com/category/economy/" class="td-post-category">Economy/Business</a>            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.somtribune.com/2022/06/04/somaliland-berbera-port-shows-true-value-of-doing-over-dithering/" rel="bookmark" title="Somaliland: Berbera Port Shows True Value of Doing Over Dithering">Somaliland: Berbera Port Shows True Value of Doing Over Dithering</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" aria-label="prev-page" id="prev-page-tdi_22" data-td_block_id="tdi_22"><i class="td-next-prev-icon td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" aria-label="next-page" id="next-page-tdi_22" data-td_block_id="tdi_22"><i class="td-next-prev-icon td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-post_format td-menu-item td-mega-menu menu-item-40667"><a href="https://www.somtribune.com/type/video/">Videos</a>
<ul class="sub-menu">
	<li class="menu-item-0"><a><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu tdi_23 td-no-subcats td_with_ajax_pagination td-pb-border-top td_block_template_1 td_ajax_preloading_preload"  data-td-block-uid="tdi_23" ><script>var block_tdi_23 = new tdBlock();
block_tdi_23.id = "tdi_23";
block_tdi_23.atts = '{"limit":"5","td_column_number":3,"ajax_pagination":"next_prev","category_id":"9155","show_child_cat":30,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"preload","block_type":"td_block_mega_menu","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"tdi_23","tdc_css_class":"tdi_23","tdc_css_class_style":"tdi_23_rand_style"}';
block_tdi_23.td_column_number = "3";
block_tdi_23.block_type = "td_block_mega_menu";
block_tdi_23.post_count = "5";
block_tdi_23.found_posts = "13";
block_tdi_23.header_color = "";
block_tdi_23.ajax_pagination_infinite_stop = "";
block_tdi_23.max_num_pages = "3";
tdBlocksArray.push(block_tdi_23);
</script><div id=tdi_23 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.somtribune.com/2020/09/23/chevening-program-trains-leaders-of-tomorrow-uk-representative-in-somaliland-republic/" rel="bookmark" class="td-image-wrap " title="Chevening Program Trains Leaders of Tomorrow &#8211; UK Representative in Somaliland Republic" ><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC"alt="" data-type="image_tag" data-img-url="https://www.somtribune.com/wp-content/plugins/td-composer/legacy/Newspaper/assets/images/no-thumb/td_218x150.png"  width="218" height="150" /><span class="td-video-play-ico"><i class="td-icon-video-thumb-play"></i></span></a></div>                <a href="https://www.somtribune.com/category/social-issues/education/" class="td-post-category">Education</a>            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.somtribune.com/2020/09/23/chevening-program-trains-leaders-of-tomorrow-uk-representative-in-somaliland-republic/" rel="bookmark" title="Chevening Program Trains Leaders of Tomorrow &#8211; UK Representative in Somaliland Republic">Chevening Program Trains Leaders of Tomorrow &#8211; UK Representative in Somaliland&#8230;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.somtribune.com/2020/05/25/somaliland-general-foohle-laid-to-rest-in-state-funeral/" rel="bookmark" class="td-image-wrap " title="Somaliland: General Foohle laid to Rest in State Funeral" ><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="Somaliland: General Foohle laid to Rest in State Funeral" data-type="image_tag" data-img-url="https://www.somtribune.com/wp-content/uploads/2020/05/sddefault-3-218x150.jpg"  width="218" height="150" /><span class="td-video-play-ico"><i class="td-icon-video-thumb-play"></i></span></a></div>                <a href="https://www.somtribune.com/category/somaliland/" class="td-post-category">Somaliland</a>            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.somtribune.com/2020/05/25/somaliland-general-foohle-laid-to-rest-in-state-funeral/" rel="bookmark" title="Somaliland: General Foohle laid to Rest in State Funeral">Somaliland: General Foohle laid to Rest in State Funeral</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.somtribune.com/2020/05/25/somaliland-covid-19-update-for-may-25/" rel="bookmark" class="td-image-wrap " title="Somaliland COVID-19 Update for May 25" ><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="Somaliland COVID-19 Update for May 25" data-type="image_tag" data-img-url="https://www.somtribune.com/wp-content/uploads/2020/05/maxresdefault-5-218x150.jpg"  width="218" height="150" /><span class="td-video-play-ico"><i class="td-icon-video-thumb-play"></i></span></a></div>                <a href="https://www.somtribune.com/category/social-issues/health/" class="td-post-category">Health</a>            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.somtribune.com/2020/05/25/somaliland-covid-19-update-for-may-25/" rel="bookmark" title="Somaliland COVID-19 Update for May 25">Somaliland COVID-19 Update for May 25</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.somtribune.com/2020/01/11/somaliland-sizable-livestock-shipment-to-leave-for-the-uae-sunday/" rel="bookmark" class="td-image-wrap " title="Somaliland: Sizable Livestock Shipment to Leave for the UAE Sunday" ><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="Somaliland: Sizable Livestock Shipment to Leave for the UAE Sunday" data-type="image_tag" data-img-url="https://www.somtribune.com/wp-content/uploads/2020/01/maxresdefault-1-218x150.jpg"  width="218" height="150" /><span class="td-video-play-ico"><i class="td-icon-video-thumb-play"></i></span></a></div>                <a href="https://www.somtribune.com/category/economy/" class="td-post-category">Economy/Business</a>            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.somtribune.com/2020/01/11/somaliland-sizable-livestock-shipment-to-leave-for-the-uae-sunday/" rel="bookmark" title="Somaliland: Sizable Livestock Shipment to Leave for the UAE Sunday">Somaliland: Sizable Livestock Shipment to Leave for the UAE Sunday</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.somtribune.com/2019/03/16/new-zealand-killer-had-trump-in-his-manifesto/" rel="bookmark" class="td-image-wrap " title="New Zealand Killer Had Trump in his Manifesto" ><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="New Zealand Killer Had Trump in his Manifesto" data-type="image_tag" data-img-url="https://www.somtribune.com/wp-content/uploads/2019/03/Manifesto-218x150.jpg"  width="218" height="150" /><span class="td-video-play-ico"><i class="td-icon-video-thumb-play"></i></span></a></div>                <a href="https://www.somtribune.com/category/worldinternational/crime-safety/" class="td-post-category">Conflict/Crime</a>            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.somtribune.com/2019/03/16/new-zealand-killer-had-trump-in-his-manifesto/" rel="bookmark" title="New Zealand Killer Had Trump in his Manifesto">New Zealand Killer Had Trump in his Manifesto</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" aria-label="prev-page" id="prev-page-tdi_23" data-td_block_id="tdi_23"><i class="td-next-prev-icon td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" aria-label="next-page" id="next-page-tdi_23" data-td_block_id="tdi_23"><i class="td-next-prev-icon td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-1087"><a href="https://www.somtribune.com/contact-us/">Contact Us</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-64392"><a href="https://www.somtribune.com/category/featured/">Featured</a></li>
</ul></div>                </div>

                <div class="td-pb-span td-sub-footer-copy">
                    &copy; SomTribune 2020, All Rights Reserved | Designed by <a href="http://somsite.com">SomSite</a>                </div>
            </div>
        </div>
    </div>
            </div><!--close td-footer-wrap-->
			
</div><!--close td-outer-wrap-->


		<script>
			jQuery( function () { window.ocvb.init( 2 ); });
		</script><div style="position:fixed;top:0px;left:8%;z-index:999999;" id="gtranslate_wrapper"><!-- GTranslate: https://gtranslate.io/ -->
<style type="text/css">
.switcher {font-family:Arial;font-size:10pt;text-align:left;cursor:pointer;overflow:hidden;width:163px;line-height:17px;}
.switcher a {text-decoration:none;display:block;font-size:10pt;-webkit-box-sizing:content-box;-moz-box-sizing:content-box;box-sizing:content-box;}
.switcher a img {vertical-align:middle;display:inline;border:0;padding:0;margin:0;opacity:0.8;}
.switcher a:hover img {opacity:1;}
.switcher .selected {background:#FFFFFF url(//www.somtribune.com/wp-content/plugins/gtranslate/switcher.png) repeat-x;position:relative;z-index:9999;}
.switcher .selected a {border:1px solid #CCCCCC;background:url(//www.somtribune.com/wp-content/plugins/gtranslate/arrow_down.png) 146px center no-repeat;color:#666666;padding:3px 5px;width:151px;}
.switcher .selected a.open {background-image:url(//www.somtribune.com/wp-content/plugins/gtranslate/arrow_up.png)}
.switcher .selected a:hover {background:#F0F0F0 url(//www.somtribune.com/wp-content/plugins/gtranslate/arrow_down.png) 146px center no-repeat;}
.switcher .option {position:relative;z-index:9998;border-left:1px solid #CCCCCC;border-right:1px solid #CCCCCC;border-bottom:1px solid #CCCCCC;background-color:#EEEEEE;display:none;width:161px;max-height:198px;-webkit-box-sizing:content-box;-moz-box-sizing:content-box;box-sizing:content-box;overflow-y:auto;overflow-x:hidden;}
.switcher .option a {color:#000;padding:3px 5px;}
.switcher .option a:hover {background:#FFC;}
.switcher .option a.selected {background:#FFC;}
#selected_lang_name {float: none;}
.l_name {float: none !important;margin: 0;}
.switcher .option::-webkit-scrollbar-track{-webkit-box-shadow:inset 0 0 3px rgba(0,0,0,0.3);border-radius:5px;background-color:#F5F5F5;}
.switcher .option::-webkit-scrollbar {width:5px;}
.switcher .option::-webkit-scrollbar-thumb {border-radius:5px;-webkit-box-shadow: inset 0 0 3px rgba(0,0,0,.3);background-color:#888;}
</style>
<div class="switcher notranslate">
<div class="selected">
<a href="#" onclick="return false;"><img src="//www.somtribune.com/wp-content/plugins/gtranslate/flags/16/en.png" height="16" width="16" alt="en" /> English</a>
</div>
<div class="option">
<a href="#" onclick="doGTranslate('en|ar');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="Arabic" class="nturl"><img data-gt-lazy-src="//www.somtribune.com/wp-content/plugins/gtranslate/flags/16/ar.png" height="16" width="16" alt="ar" /> Arabic</a><a href="#" onclick="doGTranslate('en|zh-CN');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="Chinese (Simplified)" class="nturl"><img data-gt-lazy-src="//www.somtribune.com/wp-content/plugins/gtranslate/flags/16/zh-CN.png" height="16" width="16" alt="zh-CN" /> Chinese (Simplified)</a><a href="#" onclick="doGTranslate('en|nl');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="Dutch" class="nturl"><img data-gt-lazy-src="//www.somtribune.com/wp-content/plugins/gtranslate/flags/16/nl.png" height="16" width="16" alt="nl" /> Dutch</a><a href="#" onclick="doGTranslate('en|en');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="English" class="nturl selected"><img data-gt-lazy-src="//www.somtribune.com/wp-content/plugins/gtranslate/flags/16/en.png" height="16" width="16" alt="en" /> English</a><a href="#" onclick="doGTranslate('en|fr');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="French" class="nturl"><img data-gt-lazy-src="//www.somtribune.com/wp-content/plugins/gtranslate/flags/16/fr.png" height="16" width="16" alt="fr" /> French</a><a href="#" onclick="doGTranslate('en|de');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="German" class="nturl"><img data-gt-lazy-src="//www.somtribune.com/wp-content/plugins/gtranslate/flags/16/de.png" height="16" width="16" alt="de" /> German</a><a href="#" onclick="doGTranslate('en|it');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="Italian" class="nturl"><img data-gt-lazy-src="//www.somtribune.com/wp-content/plugins/gtranslate/flags/16/it.png" height="16" width="16" alt="it" /> Italian</a><a href="#" onclick="doGTranslate('en|pt');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="Portuguese" class="nturl"><img data-gt-lazy-src="//www.somtribune.com/wp-content/plugins/gtranslate/flags/16/pt.png" height="16" width="16" alt="pt" /> Portuguese</a><a href="#" onclick="doGTranslate('en|ru');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="Russian" class="nturl"><img data-gt-lazy-src="//www.somtribune.com/wp-content/plugins/gtranslate/flags/16/ru.png" height="16" width="16" alt="ru" /> Russian</a><a href="#" onclick="doGTranslate('en|es');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="Spanish" class="nturl"><img data-gt-lazy-src="//www.somtribune.com/wp-content/plugins/gtranslate/flags/16/es.png" height="16" width="16" alt="es" /> Spanish</a></div>
</div>
<script type="text/javascript">
jQuery('.switcher .selected').click(function() {jQuery('.switcher .option a img').each(function() {if(!jQuery(this)[0].hasAttribute('src'))jQuery(this).attr('src', jQuery(this).attr('data-gt-lazy-src'))});if(!(jQuery('.switcher .option').is(':visible'))) {jQuery('.switcher .option').stop(true,true).delay(100).slideDown(500);jQuery('.switcher .selected a').toggleClass('open')}});
jQuery('.switcher .option').bind('mousewheel', function(e) {var options = jQuery('.switcher .option');if(options.is(':visible'))options.scrollTop(options.scrollTop() - e.originalEvent.wheelDelta);return false;});
jQuery('body').not('.switcher').click(function(e) {if(jQuery('.switcher .option').is(':visible') && e.target != jQuery('.switcher .option').get(0)) {jQuery('.switcher .option').stop(true,true).delay(100).slideUp(500);jQuery('.switcher .selected a').toggleClass('open')}});
</script>
<style type="text/css">
#goog-gt-tt {display:none !important;}
.goog-te-banner-frame {display:none !important;}
.goog-te-menu-value:hover {text-decoration:none !important;}
.goog-text-highlight {background-color:transparent !important;box-shadow:none !important;}
body {top:0 !important;}
#google_translate_element2 {display:none!important;}
</style>

<div id="google_translate_element2"></div>
<script type="text/javascript">
function googleTranslateElementInit2() {new google.translate.TranslateElement({pageLanguage: 'en',autoDisplay: false}, 'google_translate_element2');}
</script><script type="text/javascript" src="//translate.google.com/translate_a/element.js?cb=googleTranslateElementInit2"></script>


<script type="text/javascript">
function GTranslateGetCurrentLang() {var keyValue = document['cookie'].match('(^|;) ?googtrans=([^;]*)(;|$)');return keyValue ? keyValue[2].split('/')[2] : null;}
function GTranslateFireEvent(element,event){try{if(document.createEventObject){var evt=document.createEventObject();element.fireEvent('on'+event,evt)}else{var evt=document.createEvent('HTMLEvents');evt.initEvent(event,true,true);element.dispatchEvent(evt)}}catch(e){}}
function doGTranslate(lang_pair){if(lang_pair.value)lang_pair=lang_pair.value;if(lang_pair=='')return;var lang=lang_pair.split('|')[1];if(GTranslateGetCurrentLang() == null && lang == lang_pair.split('|')[0])return;var teCombo;var sel=document.getElementsByTagName('select');for(var i=0;i<sel.length;i++)if(/goog-te-combo/.test(sel[i].className)){teCombo=sel[i];break;}if(document.getElementById('google_translate_element2')==null||document.getElementById('google_translate_element2').innerHTML.length==0||teCombo.length==0||teCombo.innerHTML.length==0){setTimeout(function(){doGTranslate(lang_pair)},500)}else{teCombo.value=lang;GTranslateFireEvent(teCombo,'change');GTranslateFireEvent(teCombo,'change')}}
if(GTranslateGetCurrentLang() != null)jQuery(document).ready(function() {var lang_html = jQuery('div.switcher div.option').find('img[alt="'+GTranslateGetCurrentLang()+'"]').parent().html();if(typeof lang_html != 'undefined')jQuery('div.switcher div.selected a').html(lang_html.replace('data-gt-lazy-', ''));});
</script>
</div>	<div style="display:none">
			<div class="grofile-hash-map-9ee783b426530732c3ff985ea907a5fe">
		</div>
		</div>
		

    <!--

        Theme: Newspaper by tagDiv.com 2021
        Version: 11.4.1 (rara)
        Deploy mode: deploy
        
        uid: 630578165a96b
    -->

    
	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/www.somtribune.com\/2022\/08\/23\/kenya-hooligans-attempt-to-harm-iebc-officials\/":64460};
	</script>
						<script type='text/javascript' src='https://www.somtribune.com/wp-includes/js/dist/vendor/regenerator-runtime.min.js?ver=0.13.9' id='regenerator-runtime-js'></script>
<script type='text/javascript' src='https://www.somtribune.com/wp-includes/js/dist/vendor/wp-polyfill.min.js?ver=3.15.0' id='wp-polyfill-js'></script>
<script type='text/javascript' id='contact-form-7-js-extra'>
/* <![CDATA[ */
var wpcf7 = {"api":{"root":"https:\/\/www.somtribune.com\/wp-json\/","namespace":"contact-form-7\/v1"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.somtribune.com/wp-content/plugins/contact-form-7/includes/js/index.js?ver=5.6.2' id='contact-form-7-js'></script>
<script type='text/javascript' src='https://secure.gravatar.com/js/gprofiles.js?ver=202234' id='grofiles-cards-js'></script>
<script type='text/javascript' id='wpgroho-js-extra'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.somtribune.com/wp-content/plugins/jetpack/modules/wpgroho.js?ver=11.2' id='wpgroho-js'></script>
<script type='text/javascript' src='https://www.somtribune.com/wp-content/plugins/td-composer/legacy/Newspaper/js/tagdiv_theme.min.js?ver=11.4.1' id='td-site-min-js'></script>
<script type='text/javascript' src='https://www.somtribune.com/wp-includes/js/comment-reply.min.js?ver=5.9.1' id='comment-reply-js'></script>
<script type='text/javascript' src='https://www.google.com/recaptcha/api.js?render=6LcWoEQdAAAAAIRek7UGZEY5Li4mWFyiVA4_2K9o&#038;ver=3.0' id='google-recaptcha-js'></script>
<script type='text/javascript' id='wpcf7-recaptcha-js-extra'>
/* <![CDATA[ */
var wpcf7_recaptcha = {"sitekey":"6LcWoEQdAAAAAIRek7UGZEY5Li4mWFyiVA4_2K9o","actions":{"homepage":"homepage","contactform":"contactform"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.somtribune.com/wp-content/plugins/contact-form-7/modules/recaptcha/index.js?ver=5.6.2' id='wpcf7-recaptcha-js'></script>
<script type='text/javascript' src='https://cdn.onesignal.com/sdks/OneSignalSDK.js?ver=5.9.1' async='async' id='remote_sdk-js'></script>
<script type='text/javascript' src='https://www.somtribune.com/wp-content/plugins/jetpack/_inc/build/likes/queuehandler.min.js?ver=11.2' id='jetpack_likes_queuehandler-js'></script>
<script defer type='text/javascript' src='https://www.somtribune.com/wp-content/plugins/akismet/_inc/akismet-frontend.js?ver=1658863867' id='akismet-frontend-js'></script>
<script type='text/javascript' id='sharing-js-js-extra'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.somtribune.com/wp-content/plugins/jetpack/_inc/build/sharedaddy/sharing.min.js?ver=11.2' id='sharing-js-js'></script>
<script type='text/javascript' id='sharing-js-js-after'>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</script>
	<iframe src='https://widgets.wp.com/likes/master.html?ver=202234#ver=202234&#038;lang=en-gb' scrolling='no' id='likes-master' name='likes-master' style='display:none;'></iframe>
	<div id='likes-other-gravatars'><div class="likes-text"><span>%d</span> bloggers like this:</div><ul class="wpl-avatars sd-like-gravatars"></ul></div>
	
<!-- JS generated by theme -->

<script>
    
</script>

<script src='https://stats.wp.com/e-202234.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:11.2',blog:'80775917',post:'64460',tz:'3',srv:'www.somtribune.com'} ]);
	_stq.push([ 'clickTrackerInit', '80775917', '64460' ]);
</script>

</body>
</html>